summaryrefslogtreecommitdiff
path: root/extra/webkit2gtk
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-06-12 13:26:11 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-06-12 13:26:11 +0200
commitcb1266a842298fc2bb7c139c7e632d66e962a357 (patch)
treee732cba9c9d858e27e9efbff8bed0e8eed66059e /extra/webkit2gtk
parenta05d3b550f03cae50c05d79b2d373d1b1ddf6a0d (diff)
downloadpackages-cb1266a842298fc2bb7c139c7e632d66e962a357.tar.xz
extra/webkit2gtk: redone non-sse2 patch for 2.24.2
Diffstat (limited to 'extra/webkit2gtk')
-rw-r--r--extra/webkit2gtk/PKGBUILD6
-rw-r--r--extra/webkit2gtk/webkitgtk-2.24.1-no-sse2.patch44
-rw-r--r--extra/webkit2gtk/webkitgtk-2.24.2-no-sse2.patch88
3 files changed, 91 insertions, 47 deletions
diff --git a/extra/webkit2gtk/PKGBUILD b/extra/webkit2gtk/PKGBUILD
index 36799daa..a531bae6 100644
--- a/extra/webkit2gtk/PKGBUILD
+++ b/extra/webkit2gtk/PKGBUILD
@@ -1,12 +1,12 @@
# disable SSE2 on 486 and 686
if [ "$CARCH" = 'i486' -o "$CARCH" = 'i686' ]; then
- source+=('webkitgtk-2.24.1-no-sse2.patch')
- sha256sums+=('07bf1fc27fa3b92583e60297b390a6a3b048710b531f54af79a275db559bf548')
+ source+=('webkitgtk-2.24.2-no-sse2.patch')
+ sha256sums+=('bb89d3202136a5ff3c95783195efda7dfb07002cf69d8655bd11b81af95dd897')
eval "$(
declare -f prepare | \
sed '
- /cd.*/a patch -p1 < ../webkitgtk-2.24.1-no-sse2.patch
+ /cd.*/a patch -p1 < ../webkitgtk-2.24.2-no-sse2.patch
'
)"
fi
diff --git a/extra/webkit2gtk/webkitgtk-2.24.1-no-sse2.patch b/extra/webkit2gtk/webkitgtk-2.24.1-no-sse2.patch
deleted file mode 100644
index 9fdac3cc..00000000
--- a/extra/webkit2gtk/webkitgtk-2.24.1-no-sse2.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -rauN webkitgtk-2.24.1/CMakeLists.txt webkitgtk-2.24.1-no-sse2-patch/CMakeLists.txt
---- webkitgtk-2.24.1/CMakeLists.txt 2019-04-08 12:45:38.000000000 +0200
-+++ webkitgtk-2.24.1-no-sse2-patch/CMakeLists.txt 2019-05-19 12:33:45.378203751 +0200
-@@ -109,12 +109,12 @@
- #---------------------------
- # Make sure SSE2 is present.
- #---------------------------
--if (WTF_CPU_X86)
-- include(FindSSE2)
-- if (NOT SSE2_SUPPORT_FOUND)
-- message(FATAL_ERROR "SSE2 support is required to compile WebKit")
-- endif ()
--endif ()
-+#if (WTF_CPU_X86)
-+# include(FindSSE2)
-+# if (NOT SSE2_SUPPORT_FOUND)
-+# message(FATAL_ERROR "SSE2 support is required to compile WebKit")
-+# endif ()
-+#endif ()
-
- # -----------------------------------------------------------------------------
- # Determine the operating system
-diff -rauN webkitgtk-2.24.1/Source/WebCore/platform/audio/VectorMath.cpp webkitgtk-2.24.1-no-sse2-patch/Source/WebCore/platform/audio/VectorMath.cpp
---- webkitgtk-2.24.1/Source/WebCore/platform/audio/VectorMath.cpp 2019-02-12 12:21:18.000000000 +0100
-+++ webkitgtk-2.24.1-no-sse2-patch/Source/WebCore/platform/audio/VectorMath.cpp 2019-05-17 14:43:51.042171245 +0200
-@@ -33,6 +33,7 @@
- #endif
-
- #if CPU(X86_SSE2)
-+#define No SSE2
- #include <emmintrin.h>
- #endif
-
-diff -rauN webkitgtk-2.24.1/Source/WTF/wtf/Platform.h webkitgtk-2.24.1-no-sse2-patch/Source/WTF/wtf/Platform.h
---- webkitgtk-2.24.1/Source/WTF/wtf/Platform.h 2019-03-05 16:32:47.000000000 +0100
-+++ webkitgtk-2.24.1-no-sse2-patch/Source/WTF/wtf/Platform.h 2019-05-17 14:17:45.508210181 +0200
-@@ -124,6 +124,7 @@
- #define WTF_CPU_KNOWN 1
-
- #if defined(__SSE2__) || (defined(_M_IX86_FP) && _M_IX86_FP >= 2)
-+#error No SSE2
- #define WTF_CPU_X86_SSE2 1
- #endif
-
diff --git a/extra/webkit2gtk/webkitgtk-2.24.2-no-sse2.patch b/extra/webkit2gtk/webkitgtk-2.24.2-no-sse2.patch
new file mode 100644
index 00000000..5a716534
--- /dev/null
+++ b/extra/webkit2gtk/webkitgtk-2.24.2-no-sse2.patch
@@ -0,0 +1,88 @@
+diff -rauN webkitgtk-2.24.2/Source/ThirdParty/ANGLE/src/image_util/loadimage.cpp webkitgtk-2.24.2-no-sse2-patch/Source/ThirdParty/ANGLE/src/image_util/loadimage.cpp
+--- webkitgtk-2.24.2/Source/ThirdParty/ANGLE/src/image_util/loadimage.cpp 2019-02-12 12:21:03.000000000 +0100
++++ webkitgtk-2.24.2-no-sse2-patch/Source/ThirdParty/ANGLE/src/image_util/loadimage.cpp 2019-06-12 09:39:11.959999956 +0200
+@@ -12,6 +12,8 @@
+ #include "common/platform.h"
+ #include "image_util/imageformats.h"
+
++#include <stdio.h>
++
+ namespace angle
+ {
+
+@@ -28,6 +30,8 @@
+ #if defined(ANGLE_USE_SSE)
+ if (gl::supportsSSE2())
+ {
++ fprintf(stderr,"SSE2 detected but Webkit compiled without SSE2 support!\n");
++
+ __m128i zeroWide = _mm_setzero_si128();
+
+ for (size_t z = 0; z < depth; z++)
+diff -rauN webkitgtk-2.24.2/Source/ThirdParty/ANGLE/src/tests/third_party/rapidjson/include/rapidjson/rapidjson.h webkitgtk-2.24.2-no-sse2-patch/Source/ThirdParty/ANGLE/src/tests/third_party/rapidjson/include/rapidjson/rapidjson.h
+--- webkitgtk-2.24.2/Source/ThirdParty/ANGLE/src/tests/third_party/rapidjson/include/rapidjson/rapidjson.h 2019-02-12 12:21:03.000000000 +0100
++++ webkitgtk-2.24.2-no-sse2-patch/Source/ThirdParty/ANGLE/src/tests/third_party/rapidjson/include/rapidjson/rapidjson.h 2019-06-12 09:37:06.199999956 +0200
+@@ -259,6 +259,7 @@
+ */
+ #if defined(RAPIDJSON_SSE2) || defined(RAPIDJSON_SSE42) \
+ || defined(RAPIDJSON_DOXYGEN_RUNNING)
++#error No SSE2
+ #define RAPIDJSON_SIMD
+ #endif
+
+diff -rauN webkitgtk-2.24.2/Source/ThirdParty/ANGLE/src/tests/third_party/rapidjson/include/rapidjson/reader.h webkitgtk-2.24.2-no-sse2-patch/Source/ThirdParty/ANGLE/src/tests/third_party/rapidjson/include/rapidjson/reader.h
+--- webkitgtk-2.24.2/Source/ThirdParty/ANGLE/src/tests/third_party/rapidjson/include/rapidjson/reader.h 2019-02-12 12:21:03.000000000 +0100
++++ webkitgtk-2.24.2-no-sse2-patch/Source/ThirdParty/ANGLE/src/tests/third_party/rapidjson/include/rapidjson/reader.h 2019-06-12 09:36:38.209999955 +0200
+@@ -36,6 +36,7 @@
+ #ifdef RAPIDJSON_SSE42
+ #include <nmmintrin.h>
+ #elif defined(RAPIDJSON_SSE2)
++#error No SSE2
+ #include <emmintrin.h>
+ #endif
+
+diff -rauN webkitgtk-2.24.2/Source/WebCore/platform/audio/SincResampler.cpp webkitgtk-2.24.2-no-sse2-patch/Source/WebCore/platform/audio/SincResampler.cpp
+--- webkitgtk-2.24.2/Source/WebCore/platform/audio/SincResampler.cpp 2019-02-12 12:21:18.000000000 +0100
++++ webkitgtk-2.24.2-no-sse2-patch/Source/WebCore/platform/audio/SincResampler.cpp 2019-06-12 09:36:23.089999961 +0200
+@@ -36,6 +36,7 @@
+ #include <wtf/MathExtras.h>
+
+ #if CPU(X86_SSE2)
++#error No SSE2
+ #include <emmintrin.h>
+ #endif
+
+diff -rauN webkitgtk-2.24.2/Source/WebCore/platform/audio/VectorMath.cpp webkitgtk-2.24.2-no-sse2-patch/Source/WebCore/platform/audio/VectorMath.cpp
+--- webkitgtk-2.24.2/Source/WebCore/platform/audio/VectorMath.cpp 2019-02-12 12:21:18.000000000 +0100
++++ webkitgtk-2.24.2-no-sse2-patch/Source/WebCore/platform/audio/VectorMath.cpp 2019-06-12 09:09:37.576666644 +0200
+@@ -33,6 +33,7 @@
+ #endif
+
+ #if CPU(X86_SSE2)
++#error No SSE2
+ #include <emmintrin.h>
+ #endif
+
+diff -rauN webkitgtk-2.24.2/Source/WTF/wtf/Platform.h webkitgtk-2.24.2-no-sse2-patch/Source/WTF/wtf/Platform.h
+--- webkitgtk-2.24.2/Source/WTF/wtf/Platform.h 2019-03-05 16:32:47.000000000 +0100
++++ webkitgtk-2.24.2-no-sse2-patch/Source/WTF/wtf/Platform.h 2019-06-12 09:47:05.889999955 +0200
+@@ -124,7 +124,7 @@
+ #define WTF_CPU_KNOWN 1
+
+ #if defined(__SSE2__) || (defined(_M_IX86_FP) && _M_IX86_FP >= 2)
+-#define WTF_CPU_X86_SSE2 1
++/* #define WTF_CPU_X86_SSE2 1 */
+ #endif
+
+ #endif
+diff -rauN webkitgtk-2.24.2/Source/WTF/wtf/text/ASCIIFastPath.h webkitgtk-2.24.2-no-sse2-patch/Source/WTF/wtf/text/ASCIIFastPath.h
+--- webkitgtk-2.24.2/Source/WTF/wtf/text/ASCIIFastPath.h 2019-02-12 12:21:17.000000000 +0100
++++ webkitgtk-2.24.2-no-sse2-patch/Source/WTF/wtf/text/ASCIIFastPath.h 2019-06-12 09:35:37.626666634 +0200
+@@ -27,6 +27,7 @@
+ #include <wtf/text/LChar.h>
+
+ #if CPU(X86_SSE2)
++#error No SSE2
+ #include <emmintrin.h>
+ #endif
+