summaryrefslogtreecommitdiff
path: root/extra/slim
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-11-29 15:22:35 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2021-11-29 15:22:35 +0100
commit6db5befdcbf114197861fe81d5b29abb3266104a (patch)
tree9b68b3a0c21d6a89dede4da4e35826249ad4dbac /extra/slim
parent306db77dbbe88cb0f2783db4c9aa2b921339d688 (diff)
downloadpackages-6db5befdcbf114197861fe81d5b29abb3266104a.tar.xz
extra/slim: fix for FS#72873 (compilation with newer gcc)
Diffstat (limited to 'extra/slim')
-rw-r--r--extra/slim/PKGBUILD13
-rw-r--r--extra/slim/slim-1.3.6-wingc-dead-code.patch15
2 files changed, 28 insertions, 0 deletions
diff --git a/extra/slim/PKGBUILD b/extra/slim/PKGBUILD
new file mode 100644
index 00000000..3c192ffd
--- /dev/null
+++ b/extra/slim/PKGBUILD
@@ -0,0 +1,13 @@
+# temporary workaround for FS#72873
+source+=('slim-1.3.6-wingc-dead-code.patch')
+sha256sums+=('360cea8abbd2233e878319fb1e8f9acb3537a961cbd876f4098fe95bd88ec13b')
+
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i patch -Np1 -i ../slim-1.3.6-wingc-dead-code.patch
+ '
+)"
diff --git a/extra/slim/slim-1.3.6-wingc-dead-code.patch b/extra/slim/slim-1.3.6-wingc-dead-code.patch
new file mode 100644
index 00000000..37b7f578
--- /dev/null
+++ b/extra/slim/slim-1.3.6-wingc-dead-code.patch
@@ -0,0 +1,15 @@
+diff -rauN slim-1.3.6/panel.cpp slim-1.3.6-wingc-dead-code-patch/panel.cpp
+--- slim-1.3.6/panel.cpp 2013-10-02 00:38:05.000000000 +0200
++++ slim-1.3.6-wingc-dead-code-patch/panel.cpp 2021-11-29 14:59:42.948388074 +0100
+@@ -48,11 +48,6 @@
+ gcm = GCGraphicsExposures;
+ gcv.graphics_exposures = False;
+ WinGC = XCreateGC(Dpy, Win, gcm, &gcv);
+- if (WinGC < 0) {
+- cerr << APPNAME
+- << ": failed to create pixmap\n.";
+- exit(ERR_EXIT);
+- }
+ }
+
+ font = XftFontOpenName(Dpy, Scr, cfg->getOption("input_font").c_str());