summaryrefslogtreecommitdiff
path: root/extra/signond
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-05-11 12:00:35 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-05-11 12:00:35 +0200
commitda48af8f5d8e2d5c3c62e51bc00acf9f063ea131 (patch)
tree5366f1bad624192c18a0cc27d0aa51265e206393 /extra/signond
parenta57b0981e18d4fe148ceaef5548ca6e9924591e7 (diff)
downloadpackages-da48af8f5d8e2d5c3c62e51bc00acf9f063ea131.tar.xz
extra/signond: temporarily use trunk to break cycles on i486
Diffstat (limited to 'extra/signond')
-rw-r--r--extra/signond/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/extra/signond/PKGBUILD b/extra/signond/PKGBUILD
new file mode 100644
index 00000000..acd85a0b
--- /dev/null
+++ b/extra/signond/PKGBUILD
@@ -0,0 +1,31 @@
+# temporary, is fixed in trunk upstream
+
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+
+pkgname=signond
+pkgver=8.60
+pkgrel=3
+pkgdesc="A D-Bus service which performs user authentication on behalf of its clients"
+arch=(x86_64 i486 i686 pentium4)
+url="https://gitlab.com/accounts-sso/signond/"
+license=(LGPL)
+depends=(qt5-base libproxy)
+makedepends=(doxygen graphviz ttf-font qt5-tools)
+source=("https://gitlab.com/accounts-sso/signond/-/archive/VERSION_$pkgver/signond-VERSION_$pkgver.tar.bz2")
+sha256sums=('bb64fb82ecf8ce8410e61004bcb9ed5ce9da22a5aa7a80b8bb926a98f201d371')
+
+build() {
+ cd $pkgname-VERSION_$pkgver
+ qmake PREFIX=/usr LIBDIR=/usr/lib CONFIG+=rtti
+ make
+}
+
+package() {
+ cd $pkgname-VERSION_$pkgver
+ make INSTALL_ROOT="$pkgdir" install
+
+ # Do not ship docs
+ rm -rf "$pkgdir"/usr/share/doc
+}