summaryrefslogtreecommitdiff
path: root/extra/qt5-base/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-02-04 07:36:10 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2022-02-04 07:36:10 +0100
commit01a0132a1f6209640d71ce728d029187fd1644d9 (patch)
tree2a4b17ae41ab98688768347aa2d513e97f3cf682 /extra/qt5-base/PKGBUILD
parent1aed46cf2be335e618bc3c07e2b83b9ac3b6dfb3 (diff)
downloadpackages-01a0132a1f6209640d71ce728d029187fd1644d9.tar.xz
extra/qt5-base: do not build with LTO on i486 (out-of-space)
Diffstat (limited to 'extra/qt5-base/PKGBUILD')
-rw-r--r--extra/qt5-base/PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/extra/qt5-base/PKGBUILD b/extra/qt5-base/PKGBUILD
index a5a0a8e6..b7db1fd6 100644
--- a/extra/qt5-base/PKGBUILD
+++ b/extra/qt5-base/PKGBUILD
@@ -17,3 +17,13 @@ if [ "$CARCH" = 'i486' ]; then
'
)"
fi
+
+# no LTO on 486 slaves, they die with out-of-memory
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/\(.*qmake *\)CONFIG+=fat-static-lto\(.*\)/\1 \2/
+ '
+ )"
+fi