summaryrefslogtreecommitdiff
path: root/extra/python-setuptools/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-12-29 19:55:38 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2021-12-29 19:55:38 +0100
commitd53a6aa5e77d8a58ce07b2151b3f57e979d45025 (patch)
treecc4c58f1f9019177f99b9d8b9b06a8b0ffa7f20a /extra/python-setuptools/PKGBUILD
parent6c19491a6f95082cf773c59ea55c0c2c19075713 (diff)
downloadpackages-d53a6aa5e77d8a58ce07b2151b3f57e979d45025.tar.xz
extra/python-setuptools: bootstrapping
Diffstat (limited to 'extra/python-setuptools/PKGBUILD')
-rw-r--r--extra/python-setuptools/PKGBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/extra/python-setuptools/PKGBUILD b/extra/python-setuptools/PKGBUILD
index f72af23f..eba890bf 100644
--- a/extra/python-setuptools/PKGBUILD
+++ b/extra/python-setuptools/PKGBUILD
@@ -14,21 +14,23 @@ eval "$(
'
)"
-# repeat bootstrap hack from upstream, enable pip
-eval "$(
- declare -f prepare | \
- sed '
- /rm/ i \
- python -m ensurepip
- '
-)"
+unset checkdepends
+unset check
+
+makedepends=(${makedepends[@]//python-setuptools/})
+makedepends=(${makedepends[@]//python2-setuptools/})
+depends=(${depends[@]//python-pyparsing/})
+depends=(${depends[@]//python2-pyparsing/})
+makedepends+=(python python2)
+
+# bootstrapping without python2 broken stuff
+source+=('setuptools-57.4.0-no-2to3.patch')
+sha512sums+=('cb9a654825dfea7f61b394d4d7e06202569efc7f8efac5527c3653c111b349ebe182b50332d41760e1585685923b7a17d8bb3e4ada48d33aebc4c2e379e2342c')
-# force bootstrapping
eval "$(
declare -f prepare | \
sed '
- $ i \
- python bootstrap.py
- '
+ /cd/ a \
+ patch -Np1 -i "${srcdir}"/setuptools-57.4.0-no-2to3.patch
+ '
)"
-