summaryrefslogtreecommitdiff
path: root/extra/llvm12
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-11-14 18:45:26 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2021-11-14 18:45:26 +0100
commit990b229364cf9eaf401ee17cbd8d6c4981d522eb (patch)
treee55e83b315256a771f51908cf0ec0c95f87d6fcf /extra/llvm12
parentc205ac4aa24e1241bf2905aa82ffe600502a59e6 (diff)
downloadpackages-990b229364cf9eaf401ee17cbd8d6c4981d522eb.tar.xz
extra/llvm12: added shim (for rust)
Diffstat (limited to 'extra/llvm12')
-rw-r--r--extra/llvm12/PKGBUILD118
-rw-r--r--extra/llvm12/add-fno-semantic-interposition.patch21
-rw-r--r--extra/llvm12/disable-bswap-for-spir.patch50
-rw-r--r--extra/llvm12/don-t-accept-nullptr-as-GEP-element-type.patch63
-rw-r--r--extra/llvm12/llvm-config.h9
-rw-r--r--extra/llvm12/llvm-link-with-Bsymbolic-functions.patch66
-rw-r--r--extra/llvm12/no-strict-aliasing-DwarfCompileUnit.patch13
-rw-r--r--extra/llvm12/x86-twist-shuffle-mask.patch117
8 files changed, 457 insertions, 0 deletions
diff --git a/extra/llvm12/PKGBUILD b/extra/llvm12/PKGBUILD
new file mode 100644
index 00000000..873fe482
--- /dev/null
+++ b/extra/llvm12/PKGBUILD
@@ -0,0 +1,118 @@
+# Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
+# Contributor: Jan "heftig" Steffens <jan.steffens@gmail.com>
+# Changed for Archlinux32: Andreas Baumann <mail@andreasbaumann.cc>
+
+pkgname=('llvm12' 'llvm12-libs')
+pkgver=12.0.1
+pkgrel=1
+_ocaml_ver=4.12.0
+arch=(i486 i686 pentium4 'x86_64')
+url="https://llvm.org/"
+license=('custom:Apache 2.0 with LLVM Exception')
+makedepends=('cmake' 'ninja' 'libffi' 'libedit' 'ncurses' 'libxml2'
+ 'python-setuptools')
+options=('staticlibs')
+_source_base=https://github.com/llvm/llvm-project/releases/download/llvmorg-$pkgver
+source=($_source_base/llvm-$pkgver.src.tar.xz{,.sig}
+ llvm-link-with-Bsymbolic-functions.patch
+ add-fno-semantic-interposition.patch
+ x86-twist-shuffle-mask.patch
+ no-strict-aliasing-DwarfCompileUnit.patch
+ llvm-config.h)
+sha256sums=('7d9a8405f557cefc5a21bf5672af73903b64749d9bc3a50322239f56f34ffddf'
+ 'SKIP'
+ '560ce1e206c19f4b86f4c583b743db0ad47a610418999350710aafd60ae50fcd'
+ '989f7359ce1be2437e45d381e73d277bcfcabd72feb1013eb582290d47a37566'
+ 'c51b8754f76eb3774f46d530409f6d89f5bb47d90f0d718dbfa861f716b29693'
+ 'd1eff24508e35aae6c26a943dbaa3ef5acb60a145b008fd1ef9ac6f6c4faa662'
+ '597dc5968c695bbdbb0eac9e8eb5117fcd2773bc91edf5ec103ecffffab8bc48')
+validpgpkeys+=('B6C8F98282B944E3B0D5C2530FC3042E345AD05D') # Hans Wennborg <hans@chromium.org>
+validpgpkeys+=('474E22316ABF4785A88C6E8EA2C794A986419D8A') # Tom Stellard <tstellar@redhat.com>
+
+prepare() {
+ cd "$srcdir/llvm-$pkgver.src"
+ mkdir build
+
+ # https://bugs.archlinux.org/task/70697
+ patch -Np2 -i ../llvm-link-with-Bsymbolic-functions.patch
+ # https://reviews.llvm.org/D102453
+ patch -Np2 -i ../add-fno-semantic-interposition.patch
+
+ # https://bugs.llvm.org/show_bug.cgi?id=50823
+ patch -Np2 -i ../x86-twist-shuffle-mask.patch
+
+ # Work around intermittent 'clang -O -g' crashes
+ # https://bugs.llvm.org/show_bug.cgi?id=50611#c3
+ patch -Np2 -i ../no-strict-aliasing-DwarfCompileUnit.patch
+}
+
+build() {
+ cd "$srcdir/llvm-$pkgver.src/build"
+
+ cmake .. -G Ninja \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLLVM_HOST_TRIPLE=$CHOST \
+ -DLLVM_BUILD_LLVM_DYLIB=ON \
+ -DLLVM_LINK_LLVM_DYLIB=ON \
+ -DLLVM_INSTALL_UTILS=ON \
+ -DLLVM_ENABLE_RTTI=ON \
+ -DLLVM_ENABLE_FFI=ON \
+ -DLLVM_BUILD_TESTS=ON \
+ -DLLVM_BINUTILS_INCDIR=/usr/include
+ ninja all
+}
+
+check() {
+ cd "$srcdir/llvm-$pkgver.src/build"
+ ninja check
+}
+
+package_llvm12() {
+ pkgdesc="Collection of modular and reusable compiler and toolchain technologies"
+ depends=('llvm12-libs' 'perl')
+ conflicts=('llvm')
+
+ cd "$srcdir/llvm-$pkgver.src/build"
+
+ DESTDIR="$pkgdir" ninja install
+
+ # Include lit for running lit-based tests in other projects
+ pushd ../utils/lit
+ python3 setup.py install --root="$pkgdir" -O1
+ popd
+
+ # The runtime libraries go into llvm-libs
+ mv -f "$pkgdir"/usr/lib/lib{LLVM,LTO,Remarks}*.so* "$srcdir"
+ mv -f "$pkgdir"/usr/lib/LLVMgold.so "$srcdir"
+
+ install -Dm644 ../LICENSE.TXT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+package_llvm12-libs() {
+ pkgdesc="LLVM 12 runtime libraries"
+ depends=('gcc-libs' 'zlib' 'libffi' 'libedit' 'ncurses' 'libxml2')
+
+ install -d "$pkgdir/usr/lib"
+ cp -P \
+ "$srcdir"/lib{LLVM,LTO,Remarks}*.so* \
+ "$srcdir"/LLVMgold.so \
+ "$pkgdir/usr/lib/"
+
+ # Remove development symlinks
+ rm -f "$pkgdir"/usr/lib/lib{LLVM,LTO,Remarks}.so \
+ "$pkgdir"/usr/lib/LLVMgold.so
+
+ install -Dm644 "$srcdir/llvm-$pkgver.src/LICENSE.TXT" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
+# ignore failing errors in now (LLVM :: tools/gold/X86/linkonce_odr_unnamed_addr.ll)
+
+eval "$(
+ declare -f check | \
+ sed '
+ s/ninja check/ninja check || true/
+ '
+)"
diff --git a/extra/llvm12/add-fno-semantic-interposition.patch b/extra/llvm12/add-fno-semantic-interposition.patch
new file mode 100644
index 00000000..9edd3671
--- /dev/null
+++ b/extra/llvm12/add-fno-semantic-interposition.patch
@@ -0,0 +1,21 @@
+diff --git a/llvm/cmake/modules/HandleLLVMOptions.cmake b/llvm/cmake/modules/HandleLLVMOptions.cmake
+--- a/llvm/cmake/modules/HandleLLVMOptions.cmake
++++ b/llvm/cmake/modules/HandleLLVMOptions.cmake
+@@ -305,6 +305,17 @@
+ # On Windows all code is PIC. MinGW warns if -fPIC is used.
+ else()
+ add_flag_or_print_warning("-fPIC" FPIC)
++ # Enable interprocedural optimizations for non-inline functions which would
++ # otherwise be disabled due to GCC -fPIC's default.
++ #
++ # Note: Clang allows IPO for -fPIC so this optimization is less effective.
++ # Older Clang may support -fno-semantic-interposition but it used local
++ # aliases to optimize global variables, which is incompatible with copy
++ # relocations due to -fno-pic.
++ if (CMAKE_COMPILER_IS_GNUCXX OR (CMAKE_CXX_COMPILER_ID MATCHES "Clang" AND
++ CMAKE_CXX_COMPILER_VERSION GREATER_EQUAL 13))
++ add_flag_if_supported("-fno-semantic-interposition" FNO_SEMANTIC_INTERPOSITION)
++ endif()
+ endif()
+ # GCC for MIPS can miscompile LLVM due to PR37701.
+ if(CMAKE_COMPILER_IS_GNUCXX AND LLVM_NATIVE_ARCH STREQUAL "Mips" AND
diff --git a/extra/llvm12/disable-bswap-for-spir.patch b/extra/llvm12/disable-bswap-for-spir.patch
new file mode 100644
index 00000000..11385011
--- /dev/null
+++ b/extra/llvm12/disable-bswap-for-spir.patch
@@ -0,0 +1,50 @@
+# Based on https://github.com/ispc/ispc/blob/main/llvm_patches/12_0_disable-A-B-A-B-and-BSWAP-in-InstCombine.patch
+
+diff --git a/llvm/lib/Transforms/InstCombine/InstCombineAddSub.cpp b/llvm/lib/Transforms/InstCombine/InstCombineAddSub.cpp
+index d01a021bf3f4..bccce825a03d 100644
+--- a/llvm/lib/Transforms/InstCombine/InstCombineAddSub.cpp
++++ b/llvm/lib/Transforms/InstCombine/InstCombineAddSub.cpp
+@@ -15,6 +15,7 @@
+ #include "llvm/ADT/APInt.h"
+ #include "llvm/ADT/STLExtras.h"
+ #include "llvm/ADT/SmallVector.h"
++#include "llvm/ADT/Triple.h"
+ #include "llvm/Analysis/InstructionSimplify.h"
+ #include "llvm/Analysis/ValueTracking.h"
+ #include "llvm/IR/Constant.h"
+@@ -1369,9 +1370,12 @@ Instruction *InstCombinerImpl::visitAdd(BinaryOperator &I) {
+ }
+ }
+
+- // A+B --> A|B iff A and B have no bits set in common.
+- if (haveNoCommonBitsSet(LHS, RHS, DL, &AC, &I, &DT))
+- return BinaryOperator::CreateOr(LHS, RHS);
++ // Disable this transformation for ISPC SPIR-V
++ if (!Triple(I.getModule()->getTargetTriple()).isSPIR()) {
++ // A+B --> A|B iff A and B have no bits set in common.
++ if (haveNoCommonBitsSet(LHS, RHS, DL, &AC, &I, &DT))
++ return BinaryOperator::CreateOr(LHS, RHS);
++ }
+
+ // add (select X 0 (sub n A)) A --> select X A n
+ {
+diff --git a/llvm/lib/Transforms/InstCombine/InstCombineAndOrXor.cpp b/llvm/lib/Transforms/InstCombine/InstCombineAndOrXor.cpp
+index 120852c44474..8de55311ce3e 100644
+--- a/llvm/lib/Transforms/InstCombine/InstCombineAndOrXor.cpp
++++ b/llvm/lib/Transforms/InstCombine/InstCombineAndOrXor.cpp
+@@ -2671,9 +2671,12 @@ Instruction *InstCombinerImpl::visitOr(BinaryOperator &I) {
+ if (Instruction *FoldedLogic = foldBinOpIntoSelectOrPhi(I))
+ return FoldedLogic;
+
+- if (Instruction *BitOp = matchBSwapOrBitReverse(I, /*MatchBSwaps*/ true,
+- /*MatchBitReversals*/ true))
+- return BitOp;
++ // Disable this transformation for ISPC SPIR-V
++ if (!Triple(I.getModule()->getTargetTriple()).isSPIR()) {
++ if (Instruction *BitOp = matchBSwapOrBitReverse(I, /*MatchBSwaps*/ true,
++ /*MatchBitReversals*/ true))
++ return BitOp;
++ }
+
+ if (Instruction *Funnel = matchFunnelShift(I, *this))
+ return Funnel;
diff --git a/extra/llvm12/don-t-accept-nullptr-as-GEP-element-type.patch b/extra/llvm12/don-t-accept-nullptr-as-GEP-element-type.patch
new file mode 100644
index 00000000..28ab9cbe
--- /dev/null
+++ b/extra/llvm12/don-t-accept-nullptr-as-GEP-element-type.patch
@@ -0,0 +1,63 @@
+From b00cff56cfb15cbfa74cb512c9cee1c402cce55b Mon Sep 17 00:00:00 2001
+From: Nikita Popov <nikita.ppv@gmail.com>
+Date: Thu, 8 Jul 2021 20:56:05 +0200
+Subject: [PATCH] Reapply [IR] Don't accept nullptr as GEP element type
+
+Reapply after fixing another occurrence in lldb that was relying
+on this in the preceding commit.
+
+-----
+
+GetElementPtrInst::Create() (and IRBuilder methods based on it)
+currently accept nullptr as the element type, and will fetch the
+element type from the pointer in that case. Remove this fallback,
+as it is incompatible with opaque pointers. I've removed a handful
+of leftover calls using this behavior as a preliminary step.
+
+Out-of-tree code affected by this change should either pass a proper
+type, or can temporarily explicitly call getPointerElementType(),
+if the newly added assertion is encountered.
+
+Differential Revision: https://reviews.llvm.org/D105653
+---
+ llvm/include/llvm/IR/Instructions.h | 20 ++++++--------------
+ 1 file changed, 6 insertions(+), 14 deletions(-)
+
+diff --git a/llvm/include/llvm/IR/Instructions.h b/llvm/include/llvm/IR/Instructions.h
+index a5cebf0a4626..0c43a56daa33 100644
+--- a/llvm/include/llvm/IR/Instructions.h
++++ b/llvm/include/llvm/IR/Instructions.h
+@@ -956,13 +956,9 @@ public:
+ const Twine &NameStr = "",
+ Instruction *InsertBefore = nullptr) {
+ unsigned Values = 1 + unsigned(IdxList.size());
+- if (!PointeeType) {
+- PointeeType =
+- cast<PointerType>(Ptr->getType()->getScalarType())->getElementType();
+- } else {
+- assert(cast<PointerType>(Ptr->getType()->getScalarType())
+- ->isOpaqueOrPointeeTypeMatches(PointeeType));
+- }
++ assert(PointeeType && "Must specify element type");
++ assert(cast<PointerType>(Ptr->getType()->getScalarType())
++ ->isOpaqueOrPointeeTypeMatches(PointeeType));
+ return new (Values) GetElementPtrInst(PointeeType, Ptr, IdxList, Values,
+ NameStr, InsertBefore);
+ }
+@@ -972,13 +968,9 @@ public:
+ const Twine &NameStr,
+ BasicBlock *InsertAtEnd) {
+ unsigned Values = 1 + unsigned(IdxList.size());
+- if (!PointeeType) {
+- PointeeType =
+- cast<PointerType>(Ptr->getType()->getScalarType())->getElementType();
+- } else {
+- assert(cast<PointerType>(Ptr->getType()->getScalarType())
+- ->isOpaqueOrPointeeTypeMatches(PointeeType));
+- }
++ assert(PointeeType && "Must specify element type");
++ assert(cast<PointerType>(Ptr->getType()->getScalarType())
++ ->isOpaqueOrPointeeTypeMatches(PointeeType));
+ return new (Values) GetElementPtrInst(PointeeType, Ptr, IdxList, Values,
+ NameStr, InsertAtEnd);
+ }
diff --git a/extra/llvm12/llvm-config.h b/extra/llvm12/llvm-config.h
new file mode 100644
index 00000000..2fa08c9b
--- /dev/null
+++ b/extra/llvm12/llvm-config.h
@@ -0,0 +1,9 @@
+#include <bits/wordsize.h>
+
+#if __WORDSIZE == 32
+#include "llvm-config-32.h"
+#elif __WORDSIZE == 64
+#include "llvm-config-64.h"
+#else
+#error "Unknown word size"
+#endif
diff --git a/extra/llvm12/llvm-link-with-Bsymbolic-functions.patch b/extra/llvm12/llvm-link-with-Bsymbolic-functions.patch
new file mode 100644
index 00000000..b8e2e40e
--- /dev/null
+++ b/extra/llvm12/llvm-link-with-Bsymbolic-functions.patch
@@ -0,0 +1,66 @@
+From 4f05f4c8e66bc76b1d94f5283494404382e3bacd Mon Sep 17 00:00:00 2001
+From: Fangrui Song <i@maskray.me>
+Date: Thu, 13 May 2021 13:44:57 -0700
+Subject: [PATCH] [CMake][ELF] Link libLLVM.so and libclang-cpp.so with
+ -Bsymbolic-functions
+
+llvm-dev message: https://lists.llvm.org/pipermail/llvm-dev/2021-May/150465.html
+
+In an ELF shared object, a default visibility defined symbol is preemptible by
+default. This creates some missed optimization opportunities.
+-Bsymbolic-functions is more aggressive than our current -fvisibility-inlines-hidden
+(present since 2012) as it applies to all function definitions. It can
+
+* avoid PLT for cross-TU function calls && reduce dynamic symbol lookup
+* reduce dynamic symbol lookup for taking function addresses and optimize out GOT/TOC on x86-64/ppc64
+
+In a -DLLVM_TARGETS_TO_BUILD=X86 build, the number of JUMP_SLOT decreases from 12716 to 1628, and the number of GLOB_DAT decreases from 1918 to 1313
+The built clang with `-DLLVM_LINK_LLVM_DYLIB=on -DCLANG_LINK_CLANG_DYLIB=on` is significantly faster.
+See the Linux kernel build result https://bugs.archlinux.org/task/70697
+
+Note: the performance of -fno-semantic-interposition -Bsymbolic-functions
+libLLVM.so and libclang-cpp.so is close to a PIE binary linking against
+`libLLVM*.a` and `libclang*.a`. When the host compiler is Clang,
+-Bsymbolic-functions is the major contributor. On x86-64 (with GOTPCRELX) and
+ppc64 ELFv2, the GOT/TOC relocations can be optimized.
+
+Some implication:
+
+Interposing a subset of functions is no longer supported.
+(This is fragile on ELF and unsupported on Mach-O at all. For Mach-O we don't
+use `ld -interpose` or `-flat_namespace`)
+
+Compiling a program which takes the address of any LLVM function with
+`{gcc,clang} -fno-pic` and expects the address to equal to the address taken
+from libLLVM.so or libclang-cpp.so is unsupported. I am fairly confident that
+llvm-project shouldn't have different behaviors depending on such pointer
+equality (as we've been using -fvisibility-inlines-hidden which applies to
+inline functions for a long time), but if we accidentally do, users should be
+aware that they should not make assumption on pointer equality in `-fno-pic`
+mode.
+
+See more on https://maskray.me/blog/2021-05-09-fno-semantic-interposition
+
+Reviewed By: phosek
+
+Differential Revision: https://reviews.llvm.org/D102090
+---
+ llvm/tools/llvm-shlib/CMakeLists.txt | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/llvm/tools/llvm-shlib/CMakeLists.txt b/llvm/tools/llvm-shlib/CMakeLists.txt
+index b0ee19049e6f..03e1383ec8b4 100644
+--- a/llvm/tools/llvm-shlib/CMakeLists.txt
++++ b/llvm/tools/llvm-shlib/CMakeLists.txt
+@@ -50,6 +50,11 @@ if(LLVM_BUILD_LLVM_DYLIB)
+ # Solaris ld does not accept global: *; so there is no way to version *all* global symbols
+ set(LIB_NAMES -Wl,--version-script,${LLVM_LIBRARY_DIR}/tools/llvm-shlib/simple_version_script.map ${LIB_NAMES})
+ endif()
++ # Optimize function calls for default visibility definitions to avoid PLT and
++ # reduce dynamic relocations.
++ # Note: for -fno-pic default, the address of a function may be different from
++ # inside and outside libLLVM.so.
++ target_link_options(LLVM PRIVATE LINKER:-Bsymbolic-functions)
+ elseif("${CMAKE_SYSTEM_NAME}" STREQUAL "Darwin")
+ set(LIB_NAMES -Wl,-all_load ${LIB_NAMES})
+ endif()
diff --git a/extra/llvm12/no-strict-aliasing-DwarfCompileUnit.patch b/extra/llvm12/no-strict-aliasing-DwarfCompileUnit.patch
new file mode 100644
index 00000000..c7168869
--- /dev/null
+++ b/extra/llvm12/no-strict-aliasing-DwarfCompileUnit.patch
@@ -0,0 +1,13 @@
+diff --git a/llvm/lib/CodeGen/AsmPrinter/CMakeLists.txt b/llvm/lib/CodeGen/AsmPrinter/CMakeLists.txt
+index eb924282a75e..85929b54d6ce 100644
+--- a/llvm/lib/CodeGen/AsmPrinter/CMakeLists.txt
++++ b/llvm/lib/CodeGen/AsmPrinter/CMakeLists.txt
+@@ -44,3 +44,8 @@ add_llvm_component_library(LLVMAsmPrinter
+ Support
+ Target
+ )
++
++# https://bugs.llvm.org/show_bug.cgi?id=50611#c3
++if (CMAKE_COMPILER_IS_GNUCXX)
++ set_source_files_properties(DwarfCompileUnit.cpp PROPERTIES COMPILE_FLAGS -fno-strict-aliasing)
++endif()
diff --git a/extra/llvm12/x86-twist-shuffle-mask.patch b/extra/llvm12/x86-twist-shuffle-mask.patch
new file mode 100644
index 00000000..a868237b
--- /dev/null
+++ b/extra/llvm12/x86-twist-shuffle-mask.patch
@@ -0,0 +1,117 @@
+From 2c3bca2c3f13a0a9ef71d549a90fba23e6997d44 Mon Sep 17 00:00:00 2001
+From: "Wang, Pengfei" <pengfei.wang@intel.com>
+Date: Mon, 5 Jul 2021 21:08:49 +0800
+Subject: [PATCH] Twist shuffle mask when fold HOP(SHUFFLE(X,Y),SHUFFLE(X,Y))
+ -> SHUFFLE(HOP(X,Y))
+
+This patch fixes PR50823.
+
+The shuffle mask should be twisted twice before gotten the correct one due to the difference between inner HOP and outer.
+
+Reviewed By: RKSimon
+
+Differential Revision: https://reviews.llvm.org/D104903
+
+(cherry picked from commit 9ab99f773fec7da4183495a3fdc655a797d3bea2)
+---
+ llvm/lib/Target/X86/X86ISelLowering.cpp | 7 ++---
+ llvm/test/CodeGen/X86/haddsub-undef.ll | 4 +--
+ llvm/test/CodeGen/X86/packss.ll | 2 +-
+ llvm/test/CodeGen/X86/pr50823.ll | 35 +++++++++++++++++++++++++
+ 4 files changed, 42 insertions(+), 6 deletions(-)
+ create mode 100644 llvm/test/CodeGen/X86/pr50823.ll
+
+diff --git a/llvm/lib/Target/X86/X86ISelLowering.cpp b/llvm/lib/Target/X86/X86ISelLowering.cpp
+index 1e2407c7e7f6..d8b2f765e953 100644
+--- a/llvm/lib/Target/X86/X86ISelLowering.cpp
++++ b/llvm/lib/Target/X86/X86ISelLowering.cpp
+@@ -43194,9 +43194,10 @@ static SDValue combineHorizOpWithShuffle(SDNode *N, SelectionDAG &DAG,
+ ShuffleVectorSDNode::commuteMask(ShuffleMask1);
+ }
+ if ((Op00 == Op10) && (Op01 == Op11)) {
+- SmallVector<int, 4> ShuffleMask;
+- ShuffleMask.append(ShuffleMask0.begin(), ShuffleMask0.end());
+- ShuffleMask.append(ShuffleMask1.begin(), ShuffleMask1.end());
++ const int Map[4] = {0, 2, 1, 3};
++ SmallVector<int, 4> ShuffleMask(
++ {Map[ShuffleMask0[0]], Map[ShuffleMask1[0]], Map[ShuffleMask0[1]],
++ Map[ShuffleMask1[1]]});
+ SDLoc DL(N);
+ MVT ShufVT = VT.isFloatingPoint() ? MVT::v4f64 : MVT::v4i64;
+ SDValue Res = DAG.getNode(Opcode, DL, VT, Op00, Op01);
+diff --git a/llvm/test/CodeGen/X86/haddsub-undef.ll b/llvm/test/CodeGen/X86/haddsub-undef.ll
+index 68d058433179..e7c8b84d3bc7 100644
+--- a/llvm/test/CodeGen/X86/haddsub-undef.ll
++++ b/llvm/test/CodeGen/X86/haddsub-undef.ll
+@@ -1166,7 +1166,7 @@ define <4 x double> @PR34724_add_v4f64_u123(<4 x double> %0, <4 x double> %1) {
+ ; AVX512-FAST: # %bb.0:
+ ; AVX512-FAST-NEXT: vextractf128 $1, %ymm0, %xmm0
+ ; AVX512-FAST-NEXT: vhaddpd %ymm1, %ymm0, %ymm0
+-; AVX512-FAST-NEXT: vpermpd {{.*#+}} ymm0 = ymm0[0,2,0,3]
++; AVX512-FAST-NEXT: vpermpd {{.*#+}} ymm0 = ymm0[0,0,1,3]
+ ; AVX512-FAST-NEXT: retq
+ %3 = shufflevector <4 x double> %0, <4 x double> %1, <2 x i32> <i32 2, i32 4>
+ %4 = shufflevector <4 x double> %0, <4 x double> %1, <2 x i32> <i32 3, i32 5>
+@@ -1267,7 +1267,7 @@ define <4 x double> @PR34724_add_v4f64_01u3(<4 x double> %0, <4 x double> %1) {
+ ; AVX512-FAST-LABEL: PR34724_add_v4f64_01u3:
+ ; AVX512-FAST: # %bb.0:
+ ; AVX512-FAST-NEXT: vhaddpd %ymm1, %ymm0, %ymm0
+-; AVX512-FAST-NEXT: vpermpd {{.*#+}} ymm0 = ymm0[0,3,1,3]
++; AVX512-FAST-NEXT: vpermpd {{.*#+}} ymm0 = ymm0[0,2,3,3]
+ ; AVX512-FAST-NEXT: retq
+ %3 = shufflevector <4 x double> %0, <4 x double> undef, <2 x i32> <i32 0, i32 2>
+ %4 = shufflevector <4 x double> %0, <4 x double> undef, <2 x i32> <i32 1, i32 3>
+diff --git a/llvm/test/CodeGen/X86/packss.ll b/llvm/test/CodeGen/X86/packss.ll
+index 16349ae2c7f9..ac431b7556ea 100644
+--- a/llvm/test/CodeGen/X86/packss.ll
++++ b/llvm/test/CodeGen/X86/packss.ll
+@@ -370,7 +370,7 @@ define <32 x i8> @packsswb_icmp_zero_trunc_256(<16 x i16> %a0) {
+ ; AVX2-NEXT: vpxor %xmm1, %xmm1, %xmm1
+ ; AVX2-NEXT: vpcmpeqw %ymm1, %ymm0, %ymm0
+ ; AVX2-NEXT: vpacksswb %ymm0, %ymm1, %ymm0
+-; AVX2-NEXT: vpermq {{.*#+}} ymm0 = ymm0[0,0,2,3]
++; AVX2-NEXT: vpermq {{.*#+}} ymm0 = ymm0[0,1,0,3]
+ ; AVX2-NEXT: ret{{[l|q]}}
+ %1 = icmp eq <16 x i16> %a0, zeroinitializer
+ %2 = sext <16 x i1> %1 to <16 x i16>
+diff --git a/llvm/test/CodeGen/X86/pr50823.ll b/llvm/test/CodeGen/X86/pr50823.ll
+new file mode 100644
+index 000000000000..c5d5296e5c66
+--- /dev/null
++++ b/llvm/test/CodeGen/X86/pr50823.ll
+@@ -0,0 +1,35 @@
++; NOTE: Assertions have been autogenerated by utils/update_llc_test_checks.py
++; RUN: llc < %s -mtriple=x86_64-unknown -mcpu=core-avx2 | FileCheck %s
++
++%v8_uniform_FVector3 = type { float, float, float }
++
++declare <8 x float> @llvm.x86.avx.hadd.ps.256(<8 x float>, <8 x float>)
++
++define void @foo(%v8_uniform_FVector3* %Out, float* %In, <8 x i32> %__mask) {
++; CHECK-LABEL: foo:
++; CHECK: # %bb.0: # %allocas
++; CHECK-NEXT: vmovups (%rsi), %xmm0
++; CHECK-NEXT: vhaddps 32(%rsi), %xmm0, %xmm0
++; CHECK-NEXT: vpermpd {{.*#+}} ymm0 = ymm0[0,0,1,1]
++; CHECK-NEXT: vhaddps %ymm0, %ymm0, %ymm0
++; CHECK-NEXT: vextractf128 $1, %ymm0, %xmm1
++; CHECK-NEXT: vaddss %xmm1, %xmm0, %xmm0
++; CHECK-NEXT: vmovss %xmm0, (%rdi)
++; CHECK-NEXT: vzeroupper
++; CHECK-NEXT: retq
++allocas:
++ %ptr_cast_for_load = bitcast float* %In to <8 x float>*
++ %ptr_masked_load74 = load <8 x float>, <8 x float>* %ptr_cast_for_load, align 4
++ %ptr8096 = getelementptr float, float* %In, i64 8
++ %ptr_cast_for_load81 = bitcast float* %ptr8096 to <8 x float>*
++ %ptr80_masked_load82 = load <8 x float>, <8 x float>* %ptr_cast_for_load81, align 4
++ %ret_7.i.i = shufflevector <8 x float> %ptr_masked_load74, <8 x float> %ptr80_masked_load82, <8 x i32> <i32 0, i32 1, i32 2, i32 3, i32 8, i32 9, i32 10, i32 11>
++ %Out_load19 = getelementptr %v8_uniform_FVector3, %v8_uniform_FVector3* %Out, i64 0, i32 0
++ %v1.i.i100 = tail call <8 x float> @llvm.x86.avx.hadd.ps.256(<8 x float> %ret_7.i.i, <8 x float> %ret_7.i.i)
++ %v2.i.i101 = tail call <8 x float> @llvm.x86.avx.hadd.ps.256(<8 x float> %v1.i.i100, <8 x float> %v1.i.i100)
++ %scalar1.i.i102 = extractelement <8 x float> %v2.i.i101, i32 0
++ %scalar2.i.i103 = extractelement <8 x float> %v2.i.i101, i32 4
++ %sum.i.i104 = fadd float %scalar1.i.i102, %scalar2.i.i103
++ store float %sum.i.i104, float* %Out_load19, align 4
++ ret void
++}