summaryrefslogtreecommitdiff
path: root/extra/gstreamer
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-02-12 20:45:54 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2022-02-12 20:45:54 +0100
commitae5d64960b298fa325649fbbd3898ee95f8c6567 (patch)
tree57f3633cf347c3c4f3644ee6ba286367e022a18f /extra/gstreamer
parentca854b574817a9bd09da9d033c35de0abe798d0a (diff)
downloadpackages-ae5d64960b298fa325649fbbd3898ee95f8c6567.tar.xz
extra/gstreamer: more fixes not to build svthevcenc and msdk stuff
Diffstat (limited to 'extra/gstreamer')
-rw-r--r--extra/gstreamer/PKGBUILD20
1 files changed, 18 insertions, 2 deletions
diff --git a/extra/gstreamer/PKGBUILD b/extra/gstreamer/PKGBUILD
index ccfde6b2..5803f5a7 100644
--- a/extra/gstreamer/PKGBUILD
+++ b/extra/gstreamer/PKGBUILD
@@ -1,3 +1,11 @@
+# change URLs
+eval "$(
+ declare -f build | \
+ sed '
+ s|https://www.archlinux.org/|https://www.archlinux32.org/|g
+ '
+)"
+
# svt-hevc is blacklisted
makedepends=(${makedepends[@]//svt-hevc/})
@@ -5,8 +13,7 @@ eval "$(
declare -f build | \
sed '
/local meson_options.*/ a \
- meson_options+=(-D svthevcenc=disabled)
- s|https://www.archlinux.org/|https://www.archlinux32.org/|g
+ meson_options+=(-D gst-plugins-bad:svthevcenc=disabled)
'
declare -f package_gst-plugins-bad | \
sed '
@@ -18,6 +25,15 @@ eval "$(
'
)"
+#gstreamer/subprojects/gst-plugins-bad/sys/msdk/meson.build:86:4: ERROR: Problem encountered: msdk plugin enabled but the Intel Media SDK or the oneVPL SDK not found: consider setting PKG_CONFIG_PATH, INTELMEDIASDKROOT or MFX_HOME
+eval "$(
+ declare -f build | \
+ sed '
+ /local meson_options.*/ a \
+ meson_options+=(-D gst-plugins-bad:msdk=disabled)
+ '
+)"
+
# disabled testing for now, takes to long (the developers think)
# 99%: Checks: 105, Failures: 0, Errors: 1
# ../gst-plugins-base/tests/check/elements/appsrc.c:443:E:general:test_appsrc_blocked_on_caps:0: (after this point) Test timeout expired