summaryrefslogtreecommitdiff
path: root/extra/firefox
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-09-05 07:47:44 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-09-05 07:47:44 +0200
commit021409ea9d4af00e1b845eec4cd139dc715db118 (patch)
treee3cfba4c05af4904bb0cad2619773d81cae8d985 /extra/firefox
parent1c9e3fdc1be50cfe8b4a3ae9dc7a8a7a128bc42a (diff)
downloadpackages-021409ea9d4af00e1b845eec4cd139dc715db118.tar.xz
extra/firefox: building with gcc10 for now
Diffstat (limited to 'extra/firefox')
-rw-r--r--extra/firefox/PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index 03ae45d7..74d7d6ff 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -185,3 +185,21 @@ if [ "${CARCH}" = "i686" ]; then
CFLAGS="$CFLAGS -mmmx"
CXXFLAGS="$CXXFLAGS -mmmx"
fi
+
+# actually, this should be fixed in gcc 11?
+# for now let's build with gcc10
+#
+# https://bugzilla.mozilla.org/show_bug.cgi?id=1713071
+# https://bugzilla.mozilla.org/show_bug.cgi?id=1710235
+# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=100644
+#
+#11:28.22 /usr/include/c++/11.1.0/type_traits:2933:11: error: no type named ‘type’ in
+# ‘struct std::invoke_result<nsTHashtable<nsBaseHashtableET<nsUint32HashKey, RefPtr<m
+#ozilla::dom::AccessibleNode> > >::PutEntry(nsTHashtable<nsBaseHashtableET<nsUint32Ha
+#shKey, RefPtr<mozilla::dom::AccessibleNode> > >::KeyType, const fallible_t&)::<lambd
+#a(auto:7)>, mozilla::Maybe<nsTHashtable<nsBaseHashtableET<nsUint32HashKey, RefPtr<mo
+#zilla::dom::AccessibleNode> > >::EntryHandle>&&>’
+#11:28.22 2933 | using invoke_result_t = typename invoke_result<_Fn, _Args...>::
+#type;
+
+makedepends+=(gcc10)