summaryrefslogtreecommitdiff
path: root/extra/firefox/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-09-20 13:03:41 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-09-20 13:03:41 +0200
commitde84d1feaef5355846fa70d7afd8f21af07ff900 (patch)
tree46c3c41029b52c90807633e9d91b5bf04303b148 /extra/firefox/PKGBUILD
parent605381429090dabd06c6a3be73494fb8119eff4d (diff)
downloadpackages-de84d1feaef5355846fa70d7afd8f21af07ff900.tar.xz
extra/firefox: trying to handle out-of-memory and resource consumption issues
Diffstat (limited to 'extra/firefox/PKGBUILD')
-rw-r--r--extra/firefox/PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index bb213f74..0ab1e4ea 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -69,3 +69,21 @@ for ((i=0; i<${#source[@]}; i++)); do
)
fi
done
+
+# from VoidLinux, avoid excessive debug symbols in rust leading
+# to out-of-memory situations
+
+eval "$(
+ declare -f build | \
+ sed '
+ 2 a sed -i \"s/debug_info = '2'/debug_info = '1'/\" build/moz.configure/toolchain.configure
+ '
+)"
+
+# don't kill build slaves by auto-guessing available CPU cores
+eval "$(
+ declare -f build | \
+ sed '
+ 2 a export MOZ_MAKE_FLAGS=-j1
+ '
+)"