summaryrefslogtreecommitdiff
path: root/extra/chromium/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-09-29 13:33:19 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-09-29 13:33:19 +0200
commitb49853493be209110ceae4dfcee96e91a82f693d (patch)
tree3a57e0e584bfea21ac64ae1879392c4db85c49df /extra/chromium/PKGBUILD
parent141a7d7ff8933feb5b7a25b6e154172e083a1cdf (diff)
downloadpackages-b49853493be209110ceae4dfcee96e91a82f693d.tar.xz
extra/chromium: hopefully fix building and removing SSE2 for i686
Diffstat (limited to 'extra/chromium/PKGBUILD')
-rw-r--r--extra/chromium/PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/extra/chromium/PKGBUILD b/extra/chromium/PKGBUILD
index db83f313..ed4d640f 100644
--- a/extra/chromium/PKGBUILD
+++ b/extra/chromium/PKGBUILD
@@ -25,3 +25,24 @@ eval "$(
s/ninja/ninja -j 1/
'
)"
+
+# can't create dynamic relocation R_386_32 against local symbol in readonly segment
+eval "$(
+ declare -f build | \
+ sed '
+ /gn gen/ i \
+ sed -i '\''s/ldflags += [[] "-m32" []]/ldflags += [ "-m32", "-Wl,-z,notext" ]/'\'' build/config/compiler/BUILD.gn
+ '
+)"
+
+# disable SSE2 for i686 (no i486 yet, flags are in the same place for MMX and SSE math, but
+# we don't even have a gui yet)
+if [ "$CARCH" = 'i686' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ /gn gen/ i \
+ sed -i '\''s/"-msse2",/""/'\'' build/config/compiler/BUILD.gn
+ '
+ )"
+fi