summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-07-08 07:52:40 +0000
committerAndreas Baumann <mail@andreasbaumann.cc>2018-07-08 07:52:40 +0000
commitf1e8410f17ccd8d14bccdb78634508f47455fc7b (patch)
tree8dce451a731e8a5159c5b64a4c560a1466a9ee11 /core
parente924f3306d441315a28edca245a62be18bb7b454 (diff)
downloadpackages-f1e8410f17ccd8d14bccdb78634508f47455fc7b.tar.xz
core/glibc: added i486 specific patches
Diffstat (limited to 'core')
-rw-r--r--core/glibc/PKGBUILD16
1 files changed, 16 insertions, 0 deletions
diff --git a/core/glibc/PKGBUILD b/core/glibc/PKGBUILD
index e1ec16e7..12033416 100644
--- a/core/glibc/PKGBUILD
+++ b/core/glibc/PKGBUILD
@@ -26,4 +26,20 @@ eval "$(
if [ "${CARCH}" = "i486" ]; then
# no gd for memory profiles
makedepends=(${makedepends[@]//gd/})
+
+ # disable multilib, we are on 32-bit only
+ eval "$(
+ declare -f build | \
+ sed '
+ s@--enable-multi-arch@--disable-multi-arch@
+ '
+ )"
+
+ # disable testing for now, we run out of memory
+ eval "$(
+ declare -f check | \
+ sed '
+ /make check/d
+ '
+ )"
fi