summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-04-09 08:28:15 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-04-09 08:28:15 +0200
commitedfb241626f46cf2cc889825c37daf390ca3e094 (patch)
treee86b7fa8dbcd833fa03645f8a840d27c36011dd3 /core
parent119f0165ca55ba34ab19197be5e009aa0351f240 (diff)
downloadpackages-edfb241626f46cf2cc889825c37daf390ca3e094.tar.xz
core/libaio: removed all local patching
Diffstat (limited to 'core')
-rw-r--r--core/libaio/PKGBUILD23
-rw-r--r--core/libaio/libaio-0.3.111-sizeof-template.patch24
2 files changed, 0 insertions, 47 deletions
diff --git a/core/libaio/PKGBUILD b/core/libaio/PKGBUILD
deleted file mode 100644
index 1809af7b..00000000
--- a/core/libaio/PKGBUILD
+++ /dev/null
@@ -1,23 +0,0 @@
-# see also FS32#30
-# compat-0_1.c:(.text+0xaf): undefined reference to `__stack_chk_fail_local'
-eval "$(
- declare -f build | \
- sed '
- s/\(CFLAGS=.*\)/#\1/
- s@make$@CFLAGS="-march=${CARCH/_/-} -mtune=generic -O2 -pipe -fno-stack-protector" make@
- '
-)"
-
-# see also FS#60283
-source+=('libaio-0.3.111-sizeof-template.patch')
-md5sums+=('8c240ea721460fa2d34f9e134b57544d')
-eval "$(
- {
- declare -f prepare || \
- printf 'prepare() {\n}\n'
- } \
- | sed '
- $i cd "${srcdir}/${pkgname}-${pkgver}" \
- patch -Np1 -i ../libaio-0.3.111-sizeof-template.patch
- '
-)"
diff --git a/core/libaio/libaio-0.3.111-sizeof-template.patch b/core/libaio/libaio-0.3.111-sizeof-template.patch
deleted file mode 100644
index 5eee8958..00000000
--- a/core/libaio/libaio-0.3.111-sizeof-template.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -rauN libaio-0.3.111/harness/cases/19.t libaio-0.3.111-sizeof-template-patch/harness/cases/19.t
---- libaio-0.3.111/harness/cases/19.t 2018-03-06 23:24:47.000000000 +0100
-+++ libaio-0.3.111-sizeof-template-patch/harness/cases/19.t 2018-10-14 10:02:19.004873314 +0200
-@@ -41,7 +41,7 @@
- int fd;
- char template[sizeof(TEMPLATE)];
-
-- strncpy(template, TEMPLATE, sizeof(TEMPLATE));
-+ strncpy(template, TEMPLATE, sizeof(template));
- fd = mkostemp(template, O_DIRECT);
- if (fd < 0) {
- perror("mkstemp");
-diff -rauN libaio-0.3.111/harness/cases/21.t libaio-0.3.111-sizeof-template-patch/harness/cases/21.t
---- libaio-0.3.111/harness/cases/21.t 2018-03-06 23:24:47.000000000 +0100
-+++ libaio-0.3.111-sizeof-template-patch/harness/cases/21.t 2018-10-14 10:02:34.901333421 +0200
-@@ -43,7 +43,7 @@
- int fd;
- char temp_file[sizeof(TEMPLATE)];
-
-- strncpy(temp_file, TEMPLATE, sizeof(TEMPLATE));
-+ strncpy(temp_file, TEMPLATE, sizeof(temp_file));
- fd = mkstemp(temp_file);
- if (fd < 0) {
- perror("mkstemp");