summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-07-17 13:56:00 +0000
committerAndreas Baumann <mail@andreasbaumann.cc>2018-07-17 13:56:00 +0000
commitccc3a90d2823a96868590ae42b5ed70529d6a146 (patch)
tree9a1e7a88e74a3716a394d3786550b55ef18abf54 /core
parente03ac06e8ee91bd485f91002fc5ad24b429feb09 (diff)
downloadpackages-ccc3a90d2823a96868590ae42b5ed70529d6a146.tar.xz
core/shadow: added i486-specific patch
Diffstat (limited to 'core')
-rw-r--r--core/shadow/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/core/shadow/PKGBUILD b/core/shadow/PKGBUILD
new file mode 100644
index 00000000..ef3f908c
--- /dev/null
+++ b/core/shadow/PKGBUILD
@@ -0,0 +1,26 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # remove dependency on Gnome's xml2po (needed for building the man pages,
+ # draws in far too many dependencies)
+ makedepends=(${makedepends[@]//gnome-doc-utils/})
+
+ eval "$(
+ declare -f prepare | \
+ sed '
+ /autoreconf/ i \ sed -i "/SUBDIRS/s/man//g" Makefile.am
+ '
+ )"
+ eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-man/--disable-man/
+ '
+ )"
+ eval "$(
+ declare -f package | \
+ sed '
+ /find.*man/d
+ /rmdir.*man/d
+ '
+ )"
+fi