summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-11-09 09:49:55 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2018-11-09 09:49:55 +0100
commit9aea894702c1229f2b9e744c34d17dcf20f27891 (patch)
tree906cef21849c1dc1fae95e527c95e1a2008d58aa /core
parentc9295b01f38f1828fb23cebd16539e360d16d03e (diff)
downloadpackages-9aea894702c1229f2b9e744c34d17dcf20f27891.tar.xz
core/make: removed all patches, they are applied upstream
Diffstat (limited to 'core')
-rw-r--r--core/make/0001-glob-Do-not-assume-glibc-glob-internals.patch64
-rw-r--r--core/make/FS55127.patch26
-rw-r--r--core/make/FS58674.patch15
-rw-r--r--core/make/PKGBUILD12
4 files changed, 0 insertions, 117 deletions
diff --git a/core/make/0001-glob-Do-not-assume-glibc-glob-internals.patch b/core/make/0001-glob-Do-not-assume-glibc-glob-internals.patch
deleted file mode 100644
index b88ebcaf..00000000
--- a/core/make/0001-glob-Do-not-assume-glibc-glob-internals.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-From 193f1e81edd6b1b56b0eb0ff8aa4b41c7b4257b4 Mon Sep 17 00:00:00 2001
-From: Paul Eggert <eggert@cs.ucla.edu>
-Date: Sun, 24 Sep 2017 09:12:58 -0400
-Subject: [PATCH 01/26] glob: Do not assume glibc glob internals.
-
-It has been proposed that glibc glob start using gl_lstat,
-which the API allows it to do. GNU 'make' should not get in
-the way of this. See:
-https://sourceware.org/ml/libc-alpha/2017-09/msg00409.html
-
-* dir.c (local_lstat): New function, like local_stat.
-(dir_setup_glob): Use it to initialize gl_lstat too, as the API
-requires.
-
-diff --git a/dir.c b/dir.c
-index adbb8a9..c343e4c 100644
---- a/dir.c
-+++ b/dir.c
-@@ -1299,15 +1299,40 @@ local_stat (const char *path, struct stat *buf)
- }
- #endif
-
-+/* Similarly for lstat. */
-+#if !defined(lstat) && !defined(WINDOWS32) || defined(VMS)
-+# ifndef VMS
-+# ifndef HAVE_SYS_STAT_H
-+int lstat (const char *path, struct stat *sbuf);
-+# endif
-+# else
-+ /* We are done with the fake lstat. Go back to the real lstat */
-+# ifdef lstat
-+# undef lstat
-+# endif
-+# endif
-+# define local_lstat lstat
-+#elif defined(WINDOWS32)
-+/* Windows doesn't support lstat(). */
-+# define local_lstat local_stat
-+#else
-+static int
-+local_lstat (const char *path, struct stat *buf)
-+{
-+ int e;
-+ EINTRLOOP (e, lstat (path, buf));
-+ return e;
-+}
-+#endif
-+
- void
- dir_setup_glob (glob_t *gl)
- {
- gl->gl_opendir = open_dirstream;
- gl->gl_readdir = read_dirstream;
- gl->gl_closedir = free;
-+ gl->gl_lstat = local_lstat;
- gl->gl_stat = local_stat;
-- /* We don't bother setting gl_lstat, since glob never calls it.
-- The slot is only there for compatibility with 4.4 BSD. */
- }
-
- void
---
-2.18.0
-
diff --git a/core/make/FS55127.patch b/core/make/FS55127.patch
deleted file mode 100644
index 9b5291cc..00000000
--- a/core/make/FS55127.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From d9d4e06084a4c7da480bd49a3487aadf6ba77b54 Mon Sep 17 00:00:00 2001
-From: Enrique Olaizola <enrique_olaizola16@hotmail.com>
-Date: Sat, 27 May 2017 14:24:33 -0400
-Subject: * tests/run_make_tests.pl: [SV 50902] Find Perl modules
-
----
- tests/run_make_tests.pl | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/tests/run_make_tests.pl b/tests/run_make_tests.pl
-index a74417a..a844094 100644
---- a/tests/run_make_tests.pl
-+++ b/tests/run_make_tests.pl
-@@ -64,6 +64,9 @@ if ($^O eq 'VMS')
- $CMD_rmfile = 'delete_file -no_ask';
- }
-
-+use FindBin;
-+use lib "$FindBin::Bin";
-+
- require "test_driver.pl";
- require "config-flags.pm";
-
---
-cgit v1.0-41-gc330
-
diff --git a/core/make/FS58674.patch b/core/make/FS58674.patch
deleted file mode 100644
index 82f42ea5..00000000
--- a/core/make/FS58674.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -rauN make-4.2.1/configure.ac make-4.2.1-alloca-patch/configure.ac
---- make-4.2.1/configure.ac 2016-06-06 12:27:31.000000000 +0000
-+++ make-4.2.1-alloca-patch/configure.ac 2018-07-19 06:17:41.011662796 +0000
-@@ -399,10 +399,9 @@
- #include <glob.h>
- #include <fnmatch.h>
-
--#define GLOB_INTERFACE_VERSION 1
- #if !defined _LIBC && defined __GNU_LIBRARY__ && __GNU_LIBRARY__ > 1
- # include <gnu-versions.h>
--# if _GNU_GLOB_INTERFACE_VERSION == GLOB_INTERFACE_VERSION
-+# if _GNU_GLOB_INTERFACE_VERSION == 1 || _GNU_GLOB_INTERFACE_VERSION == 2
- gnu glob
- # endif
- #endif],
diff --git a/core/make/PKGBUILD b/core/make/PKGBUILD
deleted file mode 100644
index 45ca70ce..00000000
--- a/core/make/PKGBUILD
+++ /dev/null
@@ -1,12 +0,0 @@
-source+=('FS55127.patch' 'FS58674.patch' '0001-glob-Do-not-assume-glibc-glob-internals.patch')
-md5sums+=('8efba0d7ff90f5394edda0f83259af05' '95fcc032a728e134f620a402e6922389' 'a68d9cdcde0287bd2cc253a7722a2893')
-
-eval "$(
- declare -f prepare | \
- sed '
- /^\s*cd\s/a patch -p1 -i ${srcdir}/FS55127.patch
- /^\s*cd\s/a patch -p1 -i ${srcdir}/FS58674.patch
- /^\s*cd\s/a patch -p1 -i ${srcdir}/0001-glob-Do-not-assume-glibc-glob-internals.patch
- '
-)"
-