summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-06-13 09:45:24 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-06-13 09:45:24 +0200
commit9470633f4e28db261443eef2520a8d57b022c563 (patch)
tree99ea3b0bfb4899d88abc91901f964f5b1e6f5211 /core
parenta1ded77223c65b2d6a732b02511ebd29b7ecb524 (diff)
downloadpackages-9470633f4e28db261443eef2520a8d57b022c563.tar.xz
core/postfix: remove dependency on mariadb for i486
Diffstat (limited to 'core')
-rw-r--r--core/postfix/PKGBUILD13
1 files changed, 13 insertions, 0 deletions
diff --git a/core/postfix/PKGBUILD b/core/postfix/PKGBUILD
new file mode 100644
index 00000000..c69ac157
--- /dev/null
+++ b/core/postfix/PKGBUILD
@@ -0,0 +1,13 @@
+# do not make postfix depend on a micro-optimized Mysql (for i486)
+if [ "${CARCH}" = "i486" ]; then
+ depends=(${depends[@]//mariadb-libs/})
+ eval "$(
+ declare -f build | \
+ sed '
+ s|-DHAS_MYSQL -I/usr/include/mysql||g
+ s|-lmysqlclient||g
+ '
+ )"
+fi
+
+# replace $CARCH == pentium4 to i686