summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-07-19 13:20:23 +0000
committerAndreas Baumann <mail@andreasbaumann.cc>2018-07-19 13:20:23 +0000
commit7c48e3e8dfff2a52c8dd5800e60e13cbd0ec9199 (patch)
tree3a01c897eca82bf3b232bfd244d7816fc3115d30 /core
parent5060be50b2e51f418f6a578571711642c20068c9 (diff)
downloadpackages-7c48e3e8dfff2a52c8dd5800e60e13cbd0ec9199.tar.xz
core/iputils: added i486-specific patch
Diffstat (limited to 'core')
-rw-r--r--core/iputils/PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/core/iputils/PKGBUILD b/core/iputils/PKGBUILD
new file mode 100644
index 00000000..dbc14bda
--- /dev/null
+++ b/core/iputils/PKGBUILD
@@ -0,0 +1,17 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # no documentation as docbook needs sgml parsers and lots of other stuff
+ makedepends=(${makedepends[@]//docbook-utils/})
+ eval "$(
+ declare -f build | \
+ sed '
+ /make .*doc.*man/d
+ '
+ )"
+ eval "$(
+ declare -f package | \
+ sed '
+ /install.*man8/d
+ '
+ )"
+fi