summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-08-04 12:15:59 +0000
committerAndreas Baumann <mail@andreasbaumann.cc>2018-08-04 12:15:59 +0000
commit3534a6336df796b93fe2f7bf54a55ec5f3c20711 (patch)
tree80f59f700bb082f0c491c5060631dad1119af825 /core
parent002ea51da6f3d83a053e18c8b544c70399778a96 (diff)
downloadpackages-3534a6336df796b93fe2f7bf54a55ec5f3c20711.tar.xz
core/links: added i486-specific patch
Diffstat (limited to 'core')
-rw-r--r--core/links/PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/core/links/PKGBUILD b/core/links/PKGBUILD
new file mode 100644
index 00000000..5e8edb58
--- /dev/null
+++ b/core/links/PKGBUILD
@@ -0,0 +1,17 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # no X11 or graphic libraries
+ makedepends=(${makedepends[@]//libtiff/})
+ makedepends=(${makedepends[@]//libpng/})
+ makedepends=(${makedepends[@]//libxt/})
+ makedepends=(${makedepends[@]//librsvg/})
+
+ # disable xlinks (or rather, compile it the same way as links)
+ eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-graphics --with-x --with-fb/--disable-graphics --without-x --without-fb/
+ '
+ )"
+fi
+