summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-09-27 08:03:50 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2018-09-27 08:03:50 +0200
commit0c6e0b9097f9b53dd6ced279df0105c64af79fb6 (patch)
tree87e73f5a665258750d5a702336977b2048a616b7 /core
parentd2e2ecaa1c18c47f29e588e602a6c10adc534692 (diff)
downloadpackages-0c6e0b9097f9b53dd6ced279df0105c64af79fb6.tar.xz
core/dbus: temporary i486 fix (no documentation)
Diffstat (limited to 'core')
-rw-r--r--core/dbus/PKGBUILD16
1 files changed, 16 insertions, 0 deletions
diff --git a/core/dbus/PKGBUILD b/core/dbus/PKGBUILD
new file mode 100644
index 00000000..f2ad0e68
--- /dev/null
+++ b/core/dbus/PKGBUILD
@@ -0,0 +1,16 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # no documentation
+ makedepends=(${makedepends[@]//docbook-xsl/})
+ makedepends=(${makedepends[@]//yelp-tools/})
+ makedepends=(${makedepends[@]//doxygen/})
+ makedepends=(${makedepends[@]//graphviz/})
+
+ eval "$(
+ declare -f build | \
+ sed '
+ s/configure/configure --disable-xml-docs --disable-doxygen-docs --disable-ducktype-docs/
+ '
+ )"
+fi
+