summaryrefslogtreecommitdiff
path: root/core/systemd/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-03-18 08:37:52 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2021-03-18 08:37:52 +0100
commit450c33b588059e0289d5d8da0cd9c7a2d2d2dd51 (patch)
tree57e017525bbcb3ca4ce7acf47afe4297dc01ce40 /core/systemd/PKGBUILD
parentcd32c6196c179b692651fa394856b5c0f2696f5e (diff)
downloadpackages-450c33b588059e0289d5d8da0cd9c7a2d2d2dd51.tar.xz
core/systemd: temporary backport for gnu-efi (see FS#70046)
Diffstat (limited to 'core/systemd/PKGBUILD')
-rw-r--r--core/systemd/PKGBUILD14
1 files changed, 14 insertions, 0 deletions
diff --git a/core/systemd/PKGBUILD b/core/systemd/PKGBUILD
index 5ca0e402..d39d338e 100644
--- a/core/systemd/PKGBUILD
+++ b/core/systemd/PKGBUILD
@@ -8,3 +8,17 @@ eval "$(
s/meson test -C build/meson test -C build || true/
'
)"
+
+# compilation issues with gnu-efi 3.0.13
+# https://bugs.archlinux.org/task/70046?project=1&string=systemd+grub-efi&search_name=&type[0]=&sev[0]=&pri[0]=&due[0]=&reported[0]=&cat[0]=&status[0]=open&percent[0]=&opened=&dev=&closed=&duedatefrom=&duedateto=&changedfrom=&changedto=&openedfrom=&openedto=&closedfrom=&closedto=&order=dateopened&sort=desc
+# https://github.com/systemd/systemd/pull/18987
+source+=('systemd-gnu-efi.patch')
+sha512sums+=('e4e2bb0b0777a297a4c2b32b35a9a7c03e4de2ccf00f44454f1dcf0f441ba41f20d812d4771863612143a7e9b1df5e40e91b05e98de415e354b008fece3ca4da')
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ /patch/ a \
+ patch -p1 -i "$srcdir/systemd-gnu-efi.patch"
+ '
+)"