summaryrefslogtreecommitdiff
path: root/core/gpgme
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-02-14 08:00:18 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2019-02-14 08:00:18 +0100
commit4816dd87d0bf349eda4191bbaf592275ca41cc89 (patch)
treeaef87275f3d9a104ebe4174bbc562da64ae271b3 /core/gpgme
parent71c92ea4af174d3248fe82271214fffd500249b1 (diff)
downloadpackages-4816dd87d0bf349eda4191bbaf592275ca41cc89.tar.xz
core/gpgme: fix for Python 32-bit tests failing due to tes cases requiring 64-bit time_t
Diffstat (limited to 'core/gpgme')
-rw-r--r--core/gpgme/0004-Avoid-Y2038-problem-on-32-bit-architectures.patch12
-rw-r--r--core/gpgme/PKGBUILD10
2 files changed, 22 insertions, 0 deletions
diff --git a/core/gpgme/0004-Avoid-Y2038-problem-on-32-bit-architectures.patch b/core/gpgme/0004-Avoid-Y2038-problem-on-32-bit-architectures.patch
new file mode 100644
index 00000000..3c562696
--- /dev/null
+++ b/core/gpgme/0004-Avoid-Y2038-problem-on-32-bit-architectures.patch
@@ -0,0 +1,12 @@
+diff --git a/lang/python/tests/t-callbacks.py b/lang/python/tests/t-callbacks.py
+index 25a1c23..c2f9481 100755
+--- a/lang/python/tests/t-callbacks.py
++++ b/lang/python/tests/t-callbacks.py
+@@ -95,7 +95,7 @@ Name-Real: Joe Tester
+ Name-Comment: with stupid passphrase
+ Name-Email: joe+gpg@example.org
+ Passphrase: Crypt0R0cks
+-Expire-Date: 2099-12-31
++Expire-Date: 2037-12-31
+ </GnupgKeyParms>
+ """
diff --git a/core/gpgme/PKGBUILD b/core/gpgme/PKGBUILD
new file mode 100644
index 00000000..ac1ede8f
--- /dev/null
+++ b/core/gpgme/PKGBUILD
@@ -0,0 +1,10 @@
+# https://dev.gnupg.org/T4191
+# patch from Debian, see: https://salsa.debian.org/debian/gpgme/blob/debian/master/debian/patches/0004-Avoid-Y2038-problem-on-32-bit-architectures.patch
+
+source+=(0004-Avoid-Y2038-problem-on-32-bit-architectures.patch)
+sha256sums+=('0c788590e0bb7cc9da04457f94360ceef9cb9fc0525e6bfbf9fbb8d72801ae8f')
+
+prepare() {
+ cd ${pkgbase}-${pkgver}
+ patch -Np1 -i "$srcdir/0004-Avoid-Y2038-problem-on-32-bit-architectures.patch"
+}