summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-10-29 09:55:46 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-10-29 09:55:46 +0200
commite17223351da2abcc89fafb809bbd85484a1195ed (patch)
tree63f333751b4ebba414d7dc8b66bfcf1f2598c551 /community
parent68ae123d1de716968488fc85c8085c7d0b3aa8b6 (diff)
downloadpackages-e17223351da2abcc89fafb809bbd85484a1195ed.tar.xz
community/kernel-headers-musl: fixed for all Arch32 subarchs (like pentium4)
Diffstat (limited to 'community')
-rw-r--r--community/kernel-headers-musl/PKGBUILD16
1 files changed, 16 insertions, 0 deletions
diff --git a/community/kernel-headers-musl/PKGBUILD b/community/kernel-headers-musl/PKGBUILD
new file mode 100644
index 00000000..af11129f
--- /dev/null
+++ b/community/kernel-headers-musl/PKGBUILD
@@ -0,0 +1,16 @@
+# set x86 for all our sub-architectures
+# (we should actually patch ${_CARCH}, but this is too complicated for me)
+
+eval "$(
+ declare -f build | \
+ sed '
+ s/ARCH=${_CARCH}/ARCH=x86/g
+ '
+)"
+
+eval "$(
+ declare -f package | \
+ sed '
+ s/ARCH=${_CARCH}/ARCH=x86/g
+ '
+)"