summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2022-05-02 18:45:53 +0200
committerErich Eckner <git@eckner.net>2022-05-02 22:05:36 +0200
commitce243416e4ceda5325d56bfbc872d06d6b56e5a1 (patch)
treec7cb1cceb52087527a958fc8ebf883af4df7a6b5 /community
parentfc25ed0e5ef3202458be8079a61e918e383af9d8 (diff)
downloadpackages-ce243416e4ceda5325d56bfbc872d06d6b56e5a1.tar.xz
Revert "community/linux-tools: disabled archive-server"
This reverts commit b189d048bd389379b57d4436e9e3d4df3e102f95.
Diffstat (limited to 'community')
-rw-r--r--community/linux-tools/PKGBUILD116
1 files changed, 58 insertions, 58 deletions
diff --git a/community/linux-tools/PKGBUILD b/community/linux-tools/PKGBUILD
index b29bcfc1..acbe071a 100644
--- a/community/linux-tools/PKGBUILD
+++ b/community/linux-tools/PKGBUILD
@@ -1,60 +1,60 @@
# use our tarballer instead of cloning from git
-#~ for ((i=0; i<${#source[@]}; i++)); do
- #~ infos=$(
- #~ printf '%s\n' "${source[${i}]}" | \
- #~ sed '
- #~ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=[^?]\+\)$@\3 \2 \4 \5 \6@
- #~ t
- #~ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)#\(\(tag\|commit\)=[^?]\+\)\(?signed\)\?$@\3 \2 \4 \7 \5@
- #~ t
- #~ d
- #~ '
- #~ )
- #~ if [ -n "${infos}" ]; then
- #~ source[${i}]=$(
- #~ type="${infos%% *}"
- #~ infos="${infos#* }"
- #~ if [ -n "${infos%% *}" ]; then
- #~ prefix="${infos%% *}"
- #~ else
- #~ prefix=''
- #~ fi
- #~ infos="${infos#* }"
- #~ repo="${infos%% *}"
- #~ repo64=$(
- #~ printf '%s' "${repo}" | \
- #~ base64 -w0 | \
- #~ sed 's/=/%3D/g'
- #~ )
- #~ infos="${infos#* }"
- #~ if [ "${infos%% *}" = '?signed' ]; then
- #~ key_check=$(
- #~ printf '&valid_keys='
- #~ printf '%s,' "${validpgpkeys[@]}" | \
- #~ sed 's/,$//'
- #~ )
- #~ else
- #~ key_check=''
- #~ fi
- #~ infos="${infos#* }"
- #~ if [ -z "${prefix}" ]; then
- #~ prefix="${repo%.git}"
- #~ prefix="${prefix##*/}"
- #~ fi
- #~ prefix_64=$(
- #~ printf '%s/' "${prefix}" | \
- #~ base64 -w0 | \
- #~ sed 's/=/%3D/g'
- #~ )
+for ((i=0; i<${#source[@]}; i++)); do
+ infos=$(
+ printf '%s\n' "${source[${i}]}" | \
+ sed '
+ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=[^?]\+\)$@\3 \2 \4 \5 \6@
+ t
+ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)#\(\(tag\|commit\)=[^?]\+\)\(?signed\)\?$@\3 \2 \4 \7 \5@
+ t
+ d
+ '
+ )
+ if [ -n "${infos}" ]; then
+ source[${i}]=$(
+ type="${infos%% *}"
+ infos="${infos#* }"
+ if [ -n "${infos%% *}" ]; then
+ prefix="${infos%% *}"
+ else
+ prefix=''
+ fi
+ infos="${infos#* }"
+ repo="${infos%% *}"
+ repo64=$(
+ printf '%s' "${repo}" | \
+ base64 -w0 | \
+ sed 's/=/%3D/g'
+ )
+ infos="${infos#* }"
+ if [ "${infos%% *}" = '?signed' ]; then
+ key_check=$(
+ printf '&valid_keys='
+ printf '%s,' "${validpgpkeys[@]}" | \
+ sed 's/,$//'
+ )
+ else
+ key_check=''
+ fi
+ infos="${infos#* }"
+ if [ -z "${prefix}" ]; then
+ prefix="${repo%.git}"
+ prefix="${prefix##*/}"
+ fi
+ prefix_64=$(
+ printf '%s/' "${prefix}" | \
+ base64 -w0 | \
+ sed 's/=/%3D/g'
+ )
- #~ printf '%s-%s.tar.gz::https://archive-server.archlinux32.org/?t=%s&p=%s&r=%s%s&%s\n' \
- #~ "${prefix}" \
- #~ "${pkgver}" \
- #~ "${type}" \
- #~ "${prefix_64}" \
- #~ "${repo64}" \
- #~ "${key_check}" \
- #~ "${infos}"
- #~ )
- #~ fi
-#~ done
+ printf '%s-%s.tar.gz::https://archive-server.archlinux32.org/?t=%s&p=%s&r=%s%s&%s\n' \
+ "${prefix}" \
+ "${pkgver}" \
+ "${type}" \
+ "${prefix_64}" \
+ "${repo64}" \
+ "${key_check}" \
+ "${infos}"
+ )
+ fi
+done