summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-01-27 16:36:20 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2021-01-27 16:36:20 +0100
commitca914e887977bce7e86ddc5dd6c63eb53c014c60 (patch)
tree3f27872e9bb94b4338ecc8f86a8b50478a459690 /community
parentd93050451c1f09401c96cbcd9cc1bd898129d8f5 (diff)
downloadpackages-ca914e887977bce7e86ddc5dd6c63eb53c014c60.tar.xz
community/python-commonmark: breaking cycle with sphinx
Diffstat (limited to 'community')
-rw-r--r--community/python-commonmark/PKGBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/community/python-commonmark/PKGBUILD b/community/python-commonmark/PKGBUILD
new file mode 100644
index 0000000..bf73e57
--- /dev/null
+++ b/community/python-commonmark/PKGBUILD
@@ -0,0 +1,58 @@
+# cycle breaking for python-sphinx
+if [ "${CARCH}" == 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ /make.*docs.*/d
+ '
+ declare -f package | \
+ sed '
+ /install.*docs.*/d
+ '
+ )"
+ makedepends=(${makedepends[@]//python-sphinx/})
+ makedepends=(${makedepends[@]//python-sphinx_rtd_theme/})
+fi
+
+# Don't move lib32 support into rust32-lib, we are on 32-bit in the end
+# and don't draw a symlink to 64-bit libraries (but to 32-bit instead)
+
+pkgname=(
+ $(
+ printf '%s\n' "${pkgname[@]}" | \
+ grep -v '^lib32-rust-libs'
+ )
+)
+
+# remove 32-bit stuff (shouldn't that be removed automatically?)
+makedepends=(${makedepends[@]//lib32-gcc-libs/})
+
+eval "$(
+ declare -f package_rust | \
+ sed '
+ /mv.*i686-unknown-linux-gnu.*/d
+ /ln /s/x86_64-unknown-linux-gnu/i686-unknown-linux-gnu/g
+ '
+)"
+
+eval "$(
+ declare -f build | \
+ sed '
+ /mv.*i686-unknown-linux-gnu.*/d
+ /ln /s/x86_64-unknown-linux-gnu/i686-unknown-linux-gnu/g
+ '
+)"
+
+# Enable on demand, if your previous rust is broken use previous version
+# from build-support (this is preferable to using rust-bin below, but
+# requires all intermediate versions of rust to be built
+makedepends=(${makedepends[@]//rust/})
+makedepends+=('rust148')
+
+# Enable on demand, if your previous rust is broken use previous version
+# from build-support
+#makedepends=(${makedepends[@]//rust/})
+#makedepends+=('rust-bin')
+
+# rust 1.41 is built against llvm 9.0, so force that in as a make dependency
+#makedepends+=('llvm9-libs')