summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-08-20 08:36:39 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-08-20 08:36:39 +0200
commitb8b7ce74bca0c6036c77bb4b3f1decbda6b1ec25 (patch)
tree365c2bb69e45682b98155b0baf8f27985b07d54c /community
parent89f19859134be4cda68b82a2e600ad99ef6b1adf (diff)
downloadpackages-b8b7ce74bca0c6036c77bb4b3f1decbda6b1ec25.tar.xz
community/libkeccak: forgot to add the actual patch
Diffstat (limited to 'community')
-rw-r--r--community/libkeccak/PKGBUILD4
-rw-r--r--community/libkeccak/libkeccak-1.2.2-no-valgrind.patch15
2 files changed, 17 insertions, 2 deletions
diff --git a/community/libkeccak/PKGBUILD b/community/libkeccak/PKGBUILD
index b929aba6..5f1e25a0 100644
--- a/community/libkeccak/PKGBUILD
+++ b/community/libkeccak/PKGBUILD
@@ -3,8 +3,8 @@
if [ "$CARCH" = 'i486' ]; then
checkdepends=(${checkdepends[@]//valgrind/})
- source+=(libkeccak-1.2.2-no-valgrind.patch)
- b2sums+=('7a8e5b0e48db35e09cf389096f8e5d3f0cbc008f5c37ff7e88f0531f98a67fe23c25dc87b48669ef03d25a1c743516ff5bc40ed349f304c790d81bf19372026f')
+ source+=('libkeccak-1.2.2-no-valgrind.patch')
+ b2sums+=('8c8b23d104e19f1d4431e0f11e6e5995721fe1ed5a8e94ddcd28e8a09e2b11b89e7d7fec896d8b028a77560c4dbcae8f887c0d2fc1ce6f8e0c52e2f1de7a8c09')
eval "$(
{
diff --git a/community/libkeccak/libkeccak-1.2.2-no-valgrind.patch b/community/libkeccak/libkeccak-1.2.2-no-valgrind.patch
new file mode 100644
index 00000000..c8e5d977
--- /dev/null
+++ b/community/libkeccak/libkeccak-1.2.2-no-valgrind.patch
@@ -0,0 +1,15 @@
+diff -rauN libkeccak-1.2.2/Makefile libkeccak-1.2.2-no-valgrind-patch/Makefile
+--- libkeccak-1.2.2/Makefile 2021-07-30 18:59:01.000000000 +0200
++++ libkeccak-1.2.2-no-valgrind-patch/Makefile 2021-08-20 08:33:43.677087692 +0200
+@@ -159,10 +159,7 @@
+ @test $$(sha256sum .testfile | cut -d ' ' -f 1) = \
+ e21d814d21ca269246849cc105faec1a71ac7d1cdb1a86023254f49d51b47231 || \
+ ( echo 'The file .testfile is incorrect, test will fail!' ; false )
+- valgrind --leak-check=full ./test
+- test $$(valgrind ./test 2>&1 >/dev/null | wc -l) = 14
+-# Using valgrind 3.10.0, its output to standard error should consist of 14 lines,
+-# the test itself never prints to standard error.
++ ./test 2>&1 >/dev/null
+
+ benchfile:
+ dd if=/dev/urandom bs=1000 count=50 > $@