summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-06-30 18:43:30 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-06-30 18:43:30 +0200
commitb02a04bc6caff7c08251092c44cf5483912c7ad1 (patch)
tree001b34a1e27e8bc2a5466e4a279c49f09a3cb588 /community
parent2e3a761d188938b1e2d16b9ba9ff1eac908fe346 (diff)
downloadpackages-b02a04bc6caff7c08251092c44cf5483912c7ad1.tar.xz
community/exa: removed local patching, added workarounds for rust and pandoc
Diffstat (limited to 'community')
-rw-r--r--community/exa/PKGBUILD27
-rw-r--r--community/exa/exa-ascii-deprecated.patch12
2 files changed, 15 insertions, 24 deletions
diff --git a/community/exa/PKGBUILD b/community/exa/PKGBUILD
index f0d6c232..81065c10 100644
--- a/community/exa/PKGBUILD
+++ b/community/exa/PKGBUILD
@@ -1,15 +1,18 @@
-# fixed in git upstream
-
-source+=('exa-ascii-deprecated.patch')
-md5sums+=('ce36630a183f5d5be9f1a334bdf8a7cc')
+# rust currenly broken, is based on LLVM 11
+makedepends+=(llvm11)
+# pandoc is mainly broken currently (FS32#180)
+makedepends=(${makedepends[@]//pandoc/})
+eval "$(
+ declare -f build | \
+ sed '
+ s/pandoc/#pandoc/
+ '
+)"
eval "$(
- {
- declare -f prepare || \
- printf 'prepare() {\n}\n'
- } \
- | sed '
- $i cd "$srcdir/$pkgname" \
- patch -Np1 -i ../exa-ascii-deprecated.patch
- '
+ declare -f package | \
+ sed '
+ /exa.1/d
+ /exa_colors.5/d
+ '
)"
diff --git a/community/exa/exa-ascii-deprecated.patch b/community/exa/exa-ascii-deprecated.patch
deleted file mode 100644
index e4cddd6a..00000000
--- a/community/exa/exa-ascii-deprecated.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -rauN exa/src/fs/file.rs exa-ascii-deprecated-patch/src/fs/file.rs
---- exa/src/fs/file.rs 2018-12-09 12:48:21.137587385 +0100
-+++ exa-ascii-deprecated-patch/src/fs/file.rs 2018-12-09 12:59:07.048431583 +0100
-@@ -95,8 +95,6 @@
- /// against a pre-compiled list of extensions which are known to only exist
- /// within ASCII, so it’s alright.
- fn ext(path: &Path) -> Option<String> {
-- use std::ascii::AsciiExt;
--
- let name = match path.file_name() {
- Some(f) => f.to_string_lossy().to_string(),
- None => return None,