summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2018-06-20 12:48:11 +0200
committerErich Eckner <git@eckner.net>2018-06-20 12:48:11 +0200
commita00b099f8a489d7a69d37bc637b61f3ed2945414 (patch)
tree540d6f39b56df372e7d739d0cfa74b5938f6c652 /community
parent54b965bb7774abdcf6f93566b7fa3b77a5e10ab3 (diff)
downloadpackages-a00b099f8a489d7a69d37bc637b61f3ed2945414.tar.xz
community/consul: GOARCH=386
Diffstat (limited to 'community')
-rw-r--r--community/consul/PKGBUILD6
-rw-r--r--community/consul/force-pie-build.patch11
2 files changed, 17 insertions, 0 deletions
diff --git a/community/consul/PKGBUILD b/community/consul/PKGBUILD
new file mode 100644
index 00000000..2b554253
--- /dev/null
+++ b/community/consul/PKGBUILD
@@ -0,0 +1,6 @@
+for ((i=0; i<${#source[@]}; i++)); do
+ if [ "${sha512sums[${i}]}" = '2c7323b889e9a040f8e2732aa192fbef87bb5eb81072a06a48f536cbdd93d7d219ea17b61e89dfebf915e85861cbb60dd889cb03a14e0a8197b081595e2a2783' ]; then
+ break
+ fi
+done
+sha512sums[${i}]='9c74086d013b97f57609eec5bab6d6c57cb3958cc993daebe702afa95a5f3db6efa7d6f391cb118c7a8685af4442ac0aca0150003751a2e55df91eee8bee9968'
diff --git a/community/consul/force-pie-build.patch b/community/consul/force-pie-build.patch
new file mode 100644
index 00000000..81fcad92
--- /dev/null
+++ b/community/consul/force-pie-build.patch
@@ -0,0 +1,11 @@
+--- a/GNUmakefile 2018-05-22 13:25:37.236071564 +0200
++++ b/GNUmakefile 2018-05-22 13:26:44.852192711 +0200
+@@ -58,7 +58,7 @@
+ # linux builds a linux package independent of the source platform
+ linux:
+ mkdir -p pkg/linux_amd64/
+- GOOS=linux GOARCH=amd64 go build -ldflags '$(GOLDFLAGS)' -tags '$(GOTAGS)' -o pkg/linux_amd64/consul
++ GOOS=linux GOARCH=386 go build -buildmode=pie -ldflags '$(GOLDFLAGS)' -tags '$(GOTAGS)' -o pkg/linux_amd64/consul
+
+ # dist builds binaries for all platforms and packages them for distribution
+ dist: