summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-06-07 20:42:44 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-06-07 20:42:44 +0200
commit935cd710044b60c1d720e843c39edd259c5c2d6c (patch)
tree92bde08267f21e32df8a2fa5034a4ab4f9ae5437 /community
parent95c6eec3ee07b4f11861469af77da772ee3dc15f (diff)
downloadpackages-935cd710044b60c1d720e843c39edd259c5c2d6c.tar.xz
community/gcc10: fix for libgcc_s shared lib overlap
Diffstat (limited to 'community')
-rw-r--r--community/gcc10/PKGBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/community/gcc10/PKGBUILD b/community/gcc10/PKGBUILD
index 36851333..4337d994 100644
--- a/community/gcc10/PKGBUILD
+++ b/community/gcc10/PKGBUILD
@@ -79,3 +79,12 @@ else
fi
makedepends_pentium4=("${makedepends_i686[@]}")
+
+# avoid CHOST double gcc-libs
+eval "$(
+ declare -f package_gcc10 | \
+ sed '
+ /rm.*_libdir.*/ a \
+ rm -f "$pkgdir"/usr/lib/gcc/i686-pc-linux-gnu/${pkgver}/libgcc_s.so*;
+ '
+)"