summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-02-20 10:02:12 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2022-02-20 10:02:12 +0100
commit8b3c8fe3ea54e4378078344829a845f7f8a3578a (patch)
treedba8f4561da16c7773e7e90ce2b0a71fa295cea6 /community
parent28ce7f62a26fd090981a425b2d0da5ccc2ee32e1 (diff)
downloadpackages-8b3c8fe3ea54e4378078344829a845f7f8a3578a.tar.xz
community/gcc10-libs: removed, creates nothing but errors
Diffstat (limited to 'community')
-rw-r--r--community/gcc10-libs/PKGBUILD94
1 files changed, 0 insertions, 94 deletions
diff --git a/community/gcc10-libs/PKGBUILD b/community/gcc10-libs/PKGBUILD
deleted file mode 100644
index 1556c78d..00000000
--- a/community/gcc10-libs/PKGBUILD
+++ /dev/null
@@ -1,94 +0,0 @@
-# remove tsan (thread sanitizer) plugin, not available for i686
-pkgname=(
- $(
- printf '%s\n' "${pkgname[@]}" | \
- grep -vFx 'lib32-gcc-libs'
- )
-)
-unset -f 'package_lib32-gcc-libs'
-eval "$(
- declare -f prepare | \
- sed '
- \,/s/lib64/lib/, d
- '
- declare -f build | \
- sed '
- /configure/ s/--enable-multilib/--disable-multilib/
- /configure/ s,--with-bugurl=https://bugs\.archlinux\.org/,--with-bugurl=https://bugs.archlinux32.org/,
- /configure/ s/;$/ --build=$CHOST;/
- '
- declare -f package_gcc10-libs | \
- sed '
- s/\$pkgname-multilib//
- s@libsanitizer/{a,l,ub,t}san@libsanitizer/{a,l,ub}san@
- /provides=/s/libtsan.so//
- \@/usr/lib32/@ d
- '
- declare -f package_gcc10 | \
- sed '
- s/"lib32-gcc-libs[^"]*"//g
- s@make.*tsan.*install.*@#\0@
- '
-)"
-eval "$(
- for name in "${pkgname[@]}"; do
- declare -f package_${name} | \
- sed '
- s/$pkgname-multilib//
- s/{,32}//
- \,/lib32/,d
- \,/32/,d
- '
- done
-)"
-
-# i486-specific
-
-if [ "${CARCH}" = "i486" ]; then
- # building toolchain (gcc): again, lobtool problems
- # /usr/lib/gcc/i486-pc-linux-gnu/7.3.0/ld: cannot find -lquadmath
- # collect2: error: ld returned 1 exit status
- # libtool: install: error: relink `libgfortran.la' with the above command before installing it
- # make: Leaving directory '/build/gcc/src/gcc-build/i486-pc-linux-gnu/libgfortran'
- # => wrong link order: libgfortran requires libquadmath
- eval "$(
- declare -f package_gcc10-libs | \
- sed '
- /for lib in / s/libgfortran/libquadmath libgfortran/
- '
- )"
-
- # disable CET (Control Flow instructions endbr32/enbr64)
- eval "$(
- declare -f build | \
- sed '
- s/--enable-cet=auto/--disable-cet/
- '
- )"
-
-else
-
- # force enable CET (Control Flow instructions endbr32/enbr64)
- eval "$(
- declare -f build | \
- sed '
- s/--enable-cet=auto/--enable-cet/
- '
- )"
-
-fi
-
-makedepends_pentium4=("${makedepends_i686[@]}")
-
-# avoid CHOST double gcc-libs
-eval "$(
- declare -f package_gcc10 | \
- sed '
- /rm.*_libdir.*/ a \
- rm -f "$pkgdir"/usr/lib/gcc/*-pc-linux-gnu/${pkgver}/libgcc_s.so*;
- '
-)"
-
-source[1]='isl-0.24.tar.xz::https://downloads.sourceforge.net/project/libisl/isl-0.24.tar.xz?ts=gAAAAABhojIcYmUfplFkh4GCklCNjXe6c5A561-eOrQD92l7Dd9Lw5vOoApEOzfk2XL8NElrqvTKrH0enBWHiWCznbwG1pkAaQ%3D%3D&r=https%3A%2F%2Fsourceforge.net%2Fprojects%2Flibisl%2Ffiles%2Fisl-0.24.tar.xz%2Fdownload%3Fuse_mirror%3Ddeac-fra%26download%3D%26failedmirror%3Ddeac-riga.dl.sourceforge.net'
-
-unset check