summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-01-16 18:53:07 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2022-01-16 18:53:07 +0100
commit7d47d737d3d1b6c0961a08d76a37a2af32b866d2 (patch)
tree510dc8332af99b8c1501dcb014b131d6f7d58e47 /community
parent1ce5dc1daf3d041cc1e9da1179820396747b2749 (diff)
downloadpackages-7d47d737d3d1b6c0961a08d76a37a2af32b866d2.tar.xz
community/python-build: disabled docu
Diffstat (limited to 'community')
-rw-r--r--community/python-build/PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/community/python-build/PKGBUILD b/community/python-build/PKGBUILD
new file mode 100644
index 00000000..aa0b6613
--- /dev/null
+++ b/community/python-build/PKGBUILD
@@ -0,0 +1,19 @@
+# cycle breaking for python-sphinx
+eval "$(
+ declare -f build | \
+ sed '
+ /.*sphinx-build.*/d
+ '
+ declare -f package | \
+ sed '
+ /.*\/share\/doc.*/d
+ '
+)"
+
+# disable documentation (needs spinx, furo)
+# python-sphinx_furo neds npm, which is broken on archlinux32
+# most likely since years..
+makedepends=(${makedepends[@]//python-sphinx-furo/})
+makedepends=(${makedepends[@]//python-sphinx-argparse-cli/})
+makedepends=(${makedepends[@]//python-sphinx-autodoc-typehints/})
+makedepends=(${makedepends[@]//python-sphinx/})