summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-12-11 09:45:28 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2021-12-11 09:45:28 +0100
commit66bca797196c50465866b32bd2a1580060d290a1 (patch)
tree4118c93ff45178411177a6df55342930e4c4dee3 /community
parentd9858f87a18e868eabda2cb6c5635b9305067d8a (diff)
downloadpackages-66bca797196c50465866b32bd2a1580060d290a1.tar.xz
community/nodejs: more atomic and 486 trials
Diffstat (limited to 'community')
-rw-r--r--community/nodejs/PKGBUILD4
-rw-r--r--community/nodejs/node-17.1.0-atomic.patch19
2 files changed, 18 insertions, 5 deletions
diff --git a/community/nodejs/PKGBUILD b/community/nodejs/PKGBUILD
index 08611e96..0a1713cb 100644
--- a/community/nodejs/PKGBUILD
+++ b/community/nodejs/PKGBUILD
@@ -2,7 +2,7 @@
eval "$(
declare -f build | \
sed '
- s|./configure|./configure --dest-cpu ia32|g
+ s|./configure|./configure --dest-cpu x86|g
'
)"
@@ -19,7 +19,7 @@ eval "$(
# add -latomic where needed (i486)
if [ "$CARCH" = 'i486' ]; then
source+=('node-17.1.0-atomic.patch')
- sha512sums+=('0fd62af37c4c0e2cd81fc613f4610741dbe6e883b5d15aa1fd64bcdbca8ec8d95aa98a37525425e5f80e8ca1305e222235f3ca6069779e3fcc1940b20207d50a')
+ sha512sums+=('a2acca076dc0f65e17ffb5ac0bbf4dc9b8be845a400b66b5f83f5efbfca16e01ecc675a307eb0c28527874dea6464699f3969c3ee9a94226af568fb18feca331')
eval "$(
declare -f prepare | \
sed '
diff --git a/community/nodejs/node-17.1.0-atomic.patch b/community/nodejs/node-17.1.0-atomic.patch
index 58ae4ecc..fce9e21f 100644
--- a/community/nodejs/node-17.1.0-atomic.patch
+++ b/community/nodejs/node-17.1.0-atomic.patch
@@ -1,11 +1,11 @@
diff -rauN node-17.1.0/node.gyp node-17.1.0-atomic-patch/node.gyp
--- node-17.1.0/node.gyp 2021-11-08 16:40:59.000000000 +0100
-+++ node-17.1.0-atomic-patch/node.gyp 2021-12-04 12:21:17.836148103 +0100
++++ node-17.1.0-atomic-patch/node.gyp 2021-12-09 09:16:58.041503560 +0100
@@ -116,6 +116,11 @@
'-Wl,-bnoerrmsg',
],
}],
-+ [ 'host_arch=="x86"', {
++ [ 'target_arch=="ia32"', {
+ 'link_settings': {
+ 'libraries': [ '-latomic' ],
+ },
@@ -13,9 +13,22 @@ diff -rauN node-17.1.0/node.gyp node-17.1.0-atomic-patch/node.gyp
['OS == "linux" and llvm_version != "0.0"', {
'libraries': ['-latomic'],
}],
+diff -rauN node-17.1.0/tools/v8_gypfiles/toolchain.gypi node-17.1.0-atomic-patch/tools/v8_gypfiles/toolchain.gypi
+--- node-17.1.0/tools/v8_gypfiles/toolchain.gypi 2021-11-08 16:40:59.000000000 +0100
++++ node-17.1.0-atomic-patch/tools/v8_gypfiles/toolchain.gypi 2021-12-09 09:14:54.281212315 +0100
+@@ -1030,9 +1030,6 @@
+ or OS=="netbsd" or OS=="mac" or OS=="android" or OS=="qnx") and \
+ v8_target_arch=="ia32"', {
+ 'cflags': [
+- '-msse2',
+- '-mfpmath=sse',
+- '-mmmx', # Allows mmintrin.h for MMX intrinsics.
+ ],
+ }],
+ ['(OS=="linux" or OS=="freebsd" or OS=="openbsd" or OS=="solaris" \
diff -rauN node-17.1.0/tools/v8_gypfiles/v8.gyp node-17.1.0-atomic-patch/tools/v8_gypfiles/v8.gyp
--- node-17.1.0/tools/v8_gypfiles/v8.gyp 2021-11-08 16:40:59.000000000 +0100
-+++ node-17.1.0-atomic-patch/tools/v8_gypfiles/v8.gyp 2021-12-04 11:32:45.735522099 +0100
++++ node-17.1.0-atomic-patch/tools/v8_gypfiles/v8.gyp 2021-12-09 09:10:15.947439079 +0100
@@ -965,7 +965,7 @@
}],
# Platforms that don't have Compare-And-Swap (CAS) support need to link atomic library