summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-03-05 08:38:19 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2022-03-05 08:38:19 +0100
commit63ce7a8cc61a962187932d6aaca1d3537404f2bc (patch)
tree67848dcc70aab5914e1b96d06d46cd8435cf63af /community
parent636d0b01b5a6420f2865037fa3e817073127776d (diff)
downloadpackages-63ce7a8cc61a962187932d6aaca1d3537404f2bc.tar.xz
community/wireplumber: temporarily moved from extra (as the buildmaster expects it so)
Diffstat (limited to 'community')
-rw-r--r--community/wireplumber/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/wireplumber/PKGBUILD b/community/wireplumber/PKGBUILD
new file mode 100644
index 00000000..916aca78
--- /dev/null
+++ b/community/wireplumber/PKGBUILD
@@ -0,0 +1,27 @@
+# disable documentation (needs sphinx, sphinx-rtd_theme, npm)
+# python-sphinx_rdt_theme needs npm, which is broken on archlinux32
+# most likely since years..
+makedepends=(${makedepends[@]//python-sphinx_rtd_theme/})
+makedepends=(${makedepends[@]//python-sphinx/})
+eval "$(
+ declare -f build | \
+ sed '
+ /local meson_options.*/ a \
+ meson_options+=(-D doc=disabled)
+ '
+ declare -f package_wireplumber | \
+ sed '
+ /_pick.*docs.*/d
+ '
+ declare -f package_wireplumber-docs | \
+ sed '
+ /mv.*docs.*/d
+ '
+)"
+
+# for now disable testing on i486, doesn't work at all but we want
+# to satisfy dependencies and hope nobody uses it :)
+if [ "$CARCH" == 'i486' ]; then
+ unset check
+ unset checkdepends
+fi