summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-11-25 18:00:18 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2018-11-25 18:00:18 +0100
commit56f6ab488c213bd54acbe33aae23c57f6543be9b (patch)
tree26022bb631c03a97222d1ce9e552479358d7fa63 /community
parent6c7060a32732c67dda887a7976dacc912d340950 (diff)
downloadpackages-56f6ab488c213bd54acbe33aae23c57f6543be9b.tar.xz
community/hq: added patch for compiling on 32-bit
Diffstat (limited to 'community')
-rw-r--r--community/hq/PKGBUILD7
-rw-r--r--community/hq/hq-ia32.patch12
2 files changed, 19 insertions, 0 deletions
diff --git a/community/hq/PKGBUILD b/community/hq/PKGBUILD
new file mode 100644
index 00000000..4e22d247
--- /dev/null
+++ b/community/hq/PKGBUILD
@@ -0,0 +1,7 @@
+# see upstream https://github.com/coderobe/hq/pull/1
+source+=('hq-ia32.patch')
+md5sums+=('3cecc7f3b1bbe96f6c3a1609730ba574')
+prepare() {
+ cd "${pkgname}"
+ patch -Np1 -i ../hq-ia32.patch
+}
diff --git a/community/hq/hq-ia32.patch b/community/hq/hq-ia32.patch
new file mode 100644
index 00000000..07a924e0
--- /dev/null
+++ b/community/hq/hq-ia32.patch
@@ -0,0 +1,12 @@
+diff -rauN hq/main.cpp hq-ia32-patch/main.cpp
+--- hq/main.cpp 2018-11-25 17:00:49.731669567 +0100
++++ hq-ia32-patch/main.cpp 2018-11-25 17:01:32.498826389 +0100
+@@ -51,7 +51,7 @@
+ static const string afmt_s = "\033[";
+ static const string afmt_e = "m";
+ static const vector<char> collapsible = {' ', '\t', '\n', '\r'};
+-static const vector<unsigned long> breaking = {
++static const vector<myhtml_tag_id_t> breaking = {
+ MyHTML_TAG_BR,
+ MyHTML_TAG_P
+ };