summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-04-07 09:48:17 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-04-07 09:48:17 +0200
commit547306c911b08f1fe8659ef33fb26c979d0a5401 (patch)
tree36faba8f0ee7023ff65af060d95083d4dec92b44 /community
parentd5ac972a23a3307ed3d1884ffa091e9ca209f4a6 (diff)
downloadpackages-547306c911b08f1fe8659ef33fb26c979d0a5401.tar.xz
community/ispc: disabled GENX and testing
Diffstat (limited to 'community')
-rw-r--r--community/ispc/PKGBUILD41
-rw-r--r--community/ispc/ispc-1.16.1-host-amd64.patch16
2 files changed, 57 insertions, 0 deletions
diff --git a/community/ispc/PKGBUILD b/community/ispc/PKGBUILD
new file mode 100644
index 00000000..826ac9a7
--- /dev/null
+++ b/community/ispc/PKGBUILD
@@ -0,0 +1,41 @@
+# disable GENX
+eval "$(
+ declare -f build | \
+ sed '
+ s/-DGENX_ENABLED=OFF/-DGENX_ENABLED=ON/
+ '
+)"
+
+# don't assume to be on a 64-bit Intel host and draw in gnu64 headers everywhere
+source+=('ispc-1.16.1-host-amd64.patch')
+sha256sums+=('7a4a631ad178b13f9ab68e6aec94469e30a4b9dec48d40f732a701b4ed4d5c1f')
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i cd "$srcdir/$pkgname-$pkgver" \
+ patch -Np1 -i "$srcdir/ispc-1.16.1-host-amd64.patch"
+ '
+)"
+
+# ignore test results, GENX tests failing obviously
+eval "$(
+ declare -f build | \
+ sed '
+ s/\(make.*check-all\)/\1 || true/
+ '
+)"
+
+# packaging issue now as we are not building everything
+eval "$(
+ declare -f package | \
+ sed '
+ /rm.*build/d
+ /rm.*libispcrt_static.a/d
+ '
+)"
+
+# tests don't build when disabling GENX
+unset check
diff --git a/community/ispc/ispc-1.16.1-host-amd64.patch b/community/ispc/ispc-1.16.1-host-amd64.patch
new file mode 100644
index 00000000..78ef5f20
--- /dev/null
+++ b/community/ispc/ispc-1.16.1-host-amd64.patch
@@ -0,0 +1,16 @@
+diff -rauN ispc-1.16.1/CMakeLists.txt ispc-1.16.1-host-amd64-patch/CMakeLists.txt
+--- ispc-1.16.1/CMakeLists.txt 2021-07-16 01:04:31.000000000 +0200
++++ ispc-1.16.1-host-amd64-patch/CMakeLists.txt 2022-04-07 08:57:32.100539305 +0200
+@@ -45,9 +45,9 @@
+ project(${PROJECT_NAME})
+
+ set(X86_HOST FALSE)
+-if (${CMAKE_HOST_SYSTEM_PROCESSOR} MATCHES "AMD64|86")
+- set(X86_HOST TRUE)
+-endif()
++#if (${CMAKE_HOST_SYSTEM_PROCESSOR} MATCHES "AMD64|86")
++# set(X86_HOST TRUE)
++#endif()
+
+ option(X86_ENABLED "Enable x86 support" ${X86_HOST})
+ option(ARM_ENABLED "Enable ARM support" ON)