summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-10-26 21:32:44 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2018-10-26 21:32:44 +0200
commit3cf12639b379fd9ee33a5b62399504083824e41b (patch)
treef2e68c4a4a9df0b65be3d422dfea5ec19ac23bbb /community
parent77a5faaa6ea7f89e6866424e4012884d8e0fb3fe (diff)
downloadpackages-3cf12639b379fd9ee33a5b62399504083824e41b.tar.xz
community/squashfs-tools: temporary fix for FS#60439 (sysmacros include)
Diffstat (limited to 'community')
-rw-r--r--community/squashfs-tools/PKGBUILD10
-rw-r--r--community/squashfs-tools/squashfs-tools-4.3-sysmacros.patch24
2 files changed, 34 insertions, 0 deletions
diff --git a/community/squashfs-tools/PKGBUILD b/community/squashfs-tools/PKGBUILD
new file mode 100644
index 00000000..df02d5af
--- /dev/null
+++ b/community/squashfs-tools/PKGBUILD
@@ -0,0 +1,10 @@
+# see FS#60439
+
+source+=(squashfs-tools-4.3-sysmacros.patch)
+sha512sums+=('ba228d0c8e86a6a07bab9992c2484d66b1b414eb7509e0705d1bf2721486e2e4f39ed0902e257ea592107bfa8b749ee95a8360919939913ad97130277171b9a0')
+
+prepare() {
+ cd "$srcdir"/squashfs${pkgver}
+ patch -p1 < ../squashfs-tools-4.3-sysmacros.patch
+}
+
diff --git a/community/squashfs-tools/squashfs-tools-4.3-sysmacros.patch b/community/squashfs-tools/squashfs-tools-4.3-sysmacros.patch
new file mode 100644
index 00000000..14246b4a
--- /dev/null
+++ b/community/squashfs-tools/squashfs-tools-4.3-sysmacros.patch
@@ -0,0 +1,24 @@
+diff -rauN squashfs4.3/squashfs-tools/mksquashfs.c squashfs4.3-sysmacros-patch/squashfs-tools/mksquashfs.c
+--- squashfs4.3/squashfs-tools/mksquashfs.c 2014-05-13 00:18:20.000000000 +0200
++++ squashfs4.3-sysmacros-patch/squashfs-tools/mksquashfs.c 2018-10-26 21:25:02.550480701 +0200
+@@ -59,6 +59,7 @@
+ #else
+ #include <endian.h>
+ #include <sys/sysinfo.h>
++#include <sys/sysmacros.h>
+ #endif
+
+ #include "squashfs_fs.h"
+diff -rauN squashfs4.3/squashfs-tools/unsquashfs.c squashfs4.3-sysmacros-patch/squashfs-tools/unsquashfs.c
+--- squashfs4.3/squashfs-tools/unsquashfs.c 2014-05-13 00:18:35.000000000 +0200
++++ squashfs4.3-sysmacros-patch/squashfs-tools/unsquashfs.c 2018-10-26 21:25:27.830242229 +0200
+@@ -37,6 +37,9 @@
+ #include <sys/resource.h>
+ #include <limits.h>
+ #include <ctype.h>
++#ifdef linux
++#include <sys/sysmacros.h>
++#endif
+
+ struct cache *fragment_cache, *data_cache;
+ struct queue *to_reader, *to_inflate, *to_writer, *from_writer;