summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2020-03-05 10:12:42 +0100
committerErich Eckner <git@eckner.net>2020-03-05 10:12:42 +0100
commit2daf5647b6961ff6281d5c89b50783e5258a6b4b (patch)
tree0ff7915683c1d5e0095605912940f94cb65c1643 /community
parent3271f6ab8a92141c0e6e696b327198795f611006 (diff)
downloadpackages-2daf5647b6961ff6281d5c89b50783e5258a6b4b.tar.xz
do not overwrite prepare if it already existed
Diffstat (limited to 'community')
-rw-r--r--community/bazel/PKGBUILD13
-rw-r--r--community/embree/PKGBUILD14
-rw-r--r--community/exa/PKGBUILD14
-rw-r--r--community/fig2dev/PKGBUILD18
-rw-r--r--community/haskell-gauge/PKGBUILD19
-rw-r--r--community/lbzip2/PKGBUILD14
-rw-r--r--community/libnids/PKGBUILD14
-rw-r--r--community/python-libnacl/PKGBUILD18
-rw-r--r--community/smbnetfs/PKGBUILD12
-rw-r--r--community/vamp-aubio-plugins/PKGBUILD16
-rw-r--r--community/xaos/PKGBUILD16
11 files changed, 116 insertions, 52 deletions
diff --git a/community/bazel/PKGBUILD b/community/bazel/PKGBUILD
index dbf28e9b..7dd96e62 100644
--- a/community/bazel/PKGBUILD
+++ b/community/bazel/PKGBUILD
@@ -1,6 +1,11 @@
depends=("${depends[@]/java-environment>=8/java-environment=8}")
-prepare() {
- sed -i 's|#error This code for 64 bit Unix|//#error This code for 64 bit Unix|g' \
- ${srcdir}/src/tools/singlejar/mapped_file.h
-}
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i sed -i '"'"'s|#error This code for 64 bit Unix|//#error This code for 64 bit Unix|g'"'"' ${srcdir}/src/tools/singlejar/mapped_file.h
+ '
+)"
diff --git a/community/embree/PKGBUILD b/community/embree/PKGBUILD
index ee543197..522a3482 100644
--- a/community/embree/PKGBUILD
+++ b/community/embree/PKGBUILD
@@ -15,7 +15,13 @@ eval "$(
# applying a counter-patch here
source+=('embree-3.2.0-intrinsic.patch')
sha256sums+=('7d5e44a034b02e14d7d37cd038d8c279d13d66b54a449c09e0687458f117723f')
-prepare() {
- cd $pkgname-$pkgver
- patch -Np1 -i "$srcdir/embree-3.2.0-intrinsic.patch"
-}
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i cd "$srcdir/$pkgname-$pkgver" \
+ patch -Np1 -i "$srcdir/embree-3.2.0-intrinsic.patch"
+ '
+)"
diff --git a/community/exa/PKGBUILD b/community/exa/PKGBUILD
index 1de368f8..f0d6c232 100644
--- a/community/exa/PKGBUILD
+++ b/community/exa/PKGBUILD
@@ -3,7 +3,13 @@
source+=('exa-ascii-deprecated.patch')
md5sums+=('ce36630a183f5d5be9f1a334bdf8a7cc')
-prepare() {
- cd "$pkgname"
- patch -Np1 -i ../exa-ascii-deprecated.patch
-}
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i cd "$srcdir/$pkgname" \
+ patch -Np1 -i ../exa-ascii-deprecated.patch
+ '
+)"
diff --git a/community/fig2dev/PKGBUILD b/community/fig2dev/PKGBUILD
index b761add0..56b41da9 100644
--- a/community/fig2dev/PKGBUILD
+++ b/community/fig2dev/PKGBUILD
@@ -1,6 +1,12 @@
-prepare() {
- find "${pkgname}-${pkgver}" \
- -exec sed -i '
- s/Invalid resolution information (-1)\./Invalid spline object./g
- ' {} \;
-}
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i find "${srcdir}/${pkgname}-${pkgver}" \
+ -exec sed -i '"'"' \
+ s/Invalid resolution information (-1)\./Invalid spline object./g \
+ '"'"' {} \;
+ '
+)"
diff --git a/community/haskell-gauge/PKGBUILD b/community/haskell-gauge/PKGBUILD
index a5bd662e..eeba4490 100644
--- a/community/haskell-gauge/PKGBUILD
+++ b/community/haskell-gauge/PKGBUILD
@@ -1,10 +1,15 @@
# temporarily disabled 'verbose' test, see upstream:
# https://github.com/vincenthz/hs-gauge/issues/54
-prepare() {
- cd "${srcdir}/${_hkgname}-${pkgver}"
-
- sed -i '/test-suite verbose/, /test-suite quick/ { s/\(.*\)/#\1/ }' gauge.cabal
- sed -i 's/#test-suite quick/test-suite quick/' gauge.cabal
- sed -i '/^#.*/d' gauge.cabal
-}
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i cd "${srcdir}/${_hkgname}-${pkgver}" \
+ sed -i '"'"'/test-suite verbose/, /test-suite quick/ { s/\(.*\)/#\1/ }'"'"' gauge.cabal \
+ sed -i '"'"'s/#test-suite quick/test-suite quick/'"'"' gauge.cabal \
+ sed -i '"'"'/^#.*/d'"'"' gauge.cabal
+ '
+)"
diff --git a/community/lbzip2/PKGBUILD b/community/lbzip2/PKGBUILD
index 682e25f3..1bb52877 100644
--- a/community/lbzip2/PKGBUILD
+++ b/community/lbzip2/PKGBUILD
@@ -2,7 +2,13 @@
source+=('4af4a4a71827c0bc5e0ec67af23edef4f15cee8e.patch')
sha256sums+=('5eca4665b147655ce99f9ae5eff50e7db2714ba957e41e20b50d80533aeb6bef')
-prepare() {
- cd "${srcdir}"/$pkgname-$pkgver
- patch -p1 -i ../4af4a4a71827c0bc5e0ec67af23edef4f15cee8e.patch
-}
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i cd "${srcdir}"/$pkgname-$pkgver \
+ patch -p1 -i ../4af4a4a71827c0bc5e0ec67af23edef4f15cee8e.patch
+ '
+)"
diff --git a/community/libnids/PKGBUILD b/community/libnids/PKGBUILD
index 13578e05..7a510454 100644
--- a/community/libnids/PKGBUILD
+++ b/community/libnids/PKGBUILD
@@ -5,7 +5,13 @@
source+=('libnids-1.24-inline.patch')
sha256sums+=('3aea2351877c2a789d753ac66f1323a3d575dead9fb04c559e221dbebdfc7e3e')
-prepare() {
- cd $pkgname-$pkgver
- patch -Np1 -i "$srcdir/libnids-1.24-inline.patch"
-}
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i cd "$srcdir/$pkgname-$pkgver" \
+ patch -Np1 -i "$srcdir/libnids-1.24-inline.patch"
+ '
+)"
diff --git a/community/python-libnacl/PKGBUILD b/community/python-libnacl/PKGBUILD
index ca82c81d..6eda5b5e 100644
--- a/community/python-libnacl/PKGBUILD
+++ b/community/python-libnacl/PKGBUILD
@@ -1,9 +1,15 @@
# see https://bbs.archlinux32.org/viewtopic.php?pid=224
# and https://github.com/saltstack/libnacl/issues/103
-prepare() {
- sed -i '
- s/m, mlen,/m, ctypes.byref(mlen),/
- ' "libnacl-${pkgver}/libnacl/__init__.py"
- cp -r libnacl-$pkgver{,-py2}
-}
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i sed -i '"'"' \
+ s/m, mlen,/m, ctypes.byref(mlen),/ \
+ '"'"' "libnacl-${pkgver}/libnacl/__init__.py" \
+ cp -r libnacl-$pkgver{,-py2}
+ '
+)"
diff --git a/community/smbnetfs/PKGBUILD b/community/smbnetfs/PKGBUILD
index 6c6147a8..8156b28e 100644
--- a/community/smbnetfs/PKGBUILD
+++ b/community/smbnetfs/PKGBUILD
@@ -1,4 +1,10 @@
# https://sourceforge.net/p/smbnetfs/git/ci/f0e109dcc9e14b914d8f5877b4482e79d24a0ad6/
-prepare() {
- sed -i '\,^#include <attr/xattr.h>$,d' "$srcdir"/$pkgname-$pkgver/src/function.c
-}
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i sed -i '"'"'\,^#include <attr/xattr.h>$,d'"'"' "$srcdir"/$pkgname-$pkgver/src/function.c
+ '
+)"
diff --git a/community/vamp-aubio-plugins/PKGBUILD b/community/vamp-aubio-plugins/PKGBUILD
index c07e32f7..7d884b2e 100644
--- a/community/vamp-aubio-plugins/PKGBUILD
+++ b/community/vamp-aubio-plugins/PKGBUILD
@@ -1,5 +1,11 @@
-prepare() {
- sed -i '
- 48 s/x86_64/i686/
- ' vamp-aubio-plugins-0.5.1/wscript
-}
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i sed -i '"'"' \
+ 48 s/x86_64/i686/ \
+ '"'"' vamp-aubio-plugins-0.5.1/wscript
+ '
+)"
diff --git a/community/xaos/PKGBUILD b/community/xaos/PKGBUILD
index d3dd57f2..15dd3e6c 100644
--- a/community/xaos/PKGBUILD
+++ b/community/xaos/PKGBUILD
@@ -1,8 +1,14 @@
source+=('xaos.patch')
sha256sums+=('b07cdc88be38a30a40bccc2f999bff50ae8a25fc10ed4f2f7c7e2ff117f085e5')
-prepare() {
- patch -p1 -N -i "$srcdir/xaos.patch" -d "$srcdir/$pkgname-$pkgver"
- gendesk -f -n --pkgname=$pkgname --pkgdesc="$pkgdesc" \
- --categories='Application;Graphics'
-}
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i patch -p1 -N -i "$srcdir/xaos.patch" -d "$srcdir/$pkgname-$pkgver" \
+ gendesk -f -n --pkgname=$pkgname --pkgdesc="$pkgdesc" \\\
+ --categories='"'"'Application;Graphics'"'"'
+ '
+)"