summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-08-20 08:26:21 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-08-20 08:26:21 +0200
commit0b3d8bee159b5a2caf1d1253890efe32f59f6102 (patch)
tree56d5d9043ace7cac42120a1ce0f862434cd929d2 /community
parent7e7e0f534d915ea38ccf6b02f6c885f154deabf2 (diff)
downloadpackages-0b3d8bee159b5a2caf1d1253890efe32f59f6102.tar.xz
community/libkeccak: no working valgrind on 486
Diffstat (limited to 'community')
-rw-r--r--community/libkeccak/PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/community/libkeccak/PKGBUILD b/community/libkeccak/PKGBUILD
new file mode 100644
index 00000000..3f7dba36
--- /dev/null
+++ b/community/libkeccak/PKGBUILD
@@ -0,0 +1,19 @@
+# valgrind no longer supports i486 (configuire tests for the binary,
+# no explicit configure option available)
+if [ "$CARCH" = 'i486' ]; then
+ checkdepends=(${checkdepends[@]//valgrind/})
+fi
+
+source+=(libkeccak-1.2.2-no-valgrind.patch)
+b2sums+=('7a8e5b0e48db35e09cf389096f8e5d3f0cbc008f5c37ff7e88f0531f98a67fe23c25dc87b48669ef03d25a1c743516ff5bc40ed349f304c790d81bf19372026f')
+
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i cd "${srcdir}/${pkgbase}-${pkgver}" \
+ patch -Np1 -i "$srcdir/libkeccak-1.2.2-no-valgrind.patch"
+ '
+)"