summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2021-05-11 06:05:16 +0200
committerErich Eckner <git@eckner.net>2021-05-11 06:05:24 +0200
commit044ca0c03e4038471883a4c7f345b653a8498612 (patch)
tree8ec90886b7c54275013868f6556ddb4a0bd62855 /community
parent94feef39da12ac402f2fc39c7ca7e748d897e04a (diff)
downloadpackages-044ca0c03e4038471883a4c7f345b653a8498612.tar.xz
community/kea: disable mysql bindings on i486 - we don't have mariadb there for quite some time, now
Diffstat (limited to 'community')
-rw-r--r--community/kea/PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/community/kea/PKGBUILD b/community/kea/PKGBUILD
new file mode 100644
index 00000000..1d5103ad
--- /dev/null
+++ b/community/kea/PKGBUILD
@@ -0,0 +1,19 @@
+# on i486, mariadb is unavailable for quite some time, now
+
+depends=(${depends[@]//mariadb-libs/})
+depends_pentium4+=(mariadb-libs)
+depends_i686+=(mariadb-libs)
+
+eval "$(
+ declare -f build \
+ | sed '
+ /configure/ {
+ h
+ s/^/[ "$CARCH" = i486 ] || /
+ p
+ g
+ s/^/[ "$CARCH" != i486 ] || /
+ s/--with-mysql/--without-mysql/
+ }
+ '
+)"