summaryrefslogtreecommitdiff
path: root/community/sarg/no-werror.patch
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-12-18 06:29:44 +0100
committerErich Eckner <git@eckner.net>2019-12-18 06:29:44 +0100
commit0e01b9357d918985d8fb7bf76a1fb961088ed7d2 (patch)
tree2f24fee148c86f7617a39ce1d23097950752f699 /community/sarg/no-werror.patch
parent22d22242933c06544bfb5cec790dcc3df044e714 (diff)
downloadpackages-0e01b9357d918985d8fb7bf76a1fb961088ed7d2.tar.xz
community/sarg: hotfix: drop -Werror (see FS#64872)
Diffstat (limited to 'community/sarg/no-werror.patch')
-rw-r--r--community/sarg/no-werror.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/community/sarg/no-werror.patch b/community/sarg/no-werror.patch
new file mode 100644
index 00000000..7d04349b
--- /dev/null
+++ b/community/sarg/no-werror.patch
@@ -0,0 +1,23 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index aac6933..aa784ea 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -71,18 +71,6 @@ IF(HAVE_WEXTRA)
+ SET_TARGET_PROPERTIES(sarg PROPERTIES COMPILE_FLAGS "${TMPCFLAGS} -Wextra -Wno-unused-parameter")
+ ENDIF(HAVE_WEXTRA)
+
+-CHECK_C_COMPILER_FLAG("-Werror=implicit-function-declaration" HAVE_WERROR_IMPLICIT_FUNCTION)
+-IF(HAVE_WERROR_IMPLICIT_FUNCTION)
+- GET_TARGET_PROPERTY(TMPCFLAGS sarg COMPILE_FLAGS)
+- SET_TARGET_PROPERTIES(sarg PROPERTIES COMPILE_FLAGS "${TMPCFLAGS} -Werror=implicit-function-declaration")
+-ENDIF(HAVE_WERROR_IMPLICIT_FUNCTION)
+-
+-CHECK_C_COMPILER_FLAG("-Werror=format" HAVE_WERROR_FORMAT)
+-IF(HAVE_WERROR_FORMAT)
+- GET_TARGET_PROPERTY(TMPCFLAGS sarg COMPILE_FLAGS)
+- SET_TARGET_PROPERTIES(sarg PROPERTIES COMPILE_FLAGS "${TMPCFLAGS} -Werror=format")
+-ENDIF(HAVE_WERROR_FORMAT)
+-
+ # Required header files
+ CHECK_INCLUDE_FILE(stdio.h HAVE_STDIO_H)
+ CHECK_INCLUDE_FILE(stdlib.h HAVE_STDLIB_H)