summaryrefslogtreecommitdiff
path: root/community/nodejs/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-12-05 09:57:28 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2021-12-05 09:57:28 +0100
commitb9e5cfbaf37c187934d23c11f9a07b723c21be6b (patch)
tree44c62939f41d313f06725906a03f3f257b863cc9 /community/nodejs/PKGBUILD
parent67e4912813a1eb15a2b8000cc1e1c5da1deafc72 (diff)
downloadpackages-b9e5cfbaf37c187934d23c11f9a07b723c21be6b.tar.xz
community/nodejs: fixed patching in wrong place
Diffstat (limited to 'community/nodejs/PKGBUILD')
-rw-r--r--community/nodejs/PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/community/nodejs/PKGBUILD b/community/nodejs/PKGBUILD
index efbf8000..08611e96 100644
--- a/community/nodejs/PKGBUILD
+++ b/community/nodejs/PKGBUILD
@@ -15,3 +15,21 @@ eval "$(
3 i CXXFLAGS+=" -g1"
'
)"
+
+# add -latomic where needed (i486)
+if [ "$CARCH" = 'i486' ]; then
+ source+=('node-17.1.0-atomic.patch')
+ sha512sums+=('0fd62af37c4c0e2cd81fc613f4610741dbe6e883b5d15aa1fd64bcdbca8ec8d95aa98a37525425e5f80e8ca1305e222235f3ca6069779e3fcc1940b20207d50a')
+ eval "$(
+ declare -f prepare | \
+ sed '
+ $i patch -Np1 -i "../node-17.1.0-atomic.patch"
+ '
+ )"
+ eval "$(
+ declare -f build | \
+ sed '
+ 3 i LDFLAGS+=" -latomic"
+ '
+ )"
+fi