summaryrefslogtreecommitdiff
path: root/community/grpc
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-08-29 11:51:06 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-08-29 11:51:06 +0200
commit7174b177e1d4a7850c61afb258ab7561a33f8a57 (patch)
treeef66f04094296c09600729c0b579164436270a88 /community/grpc
parent1289d1fbcfbf37c6547791580bb3337a85195572 (diff)
downloadpackages-7174b177e1d4a7850c61afb258ab7561a33f8a57.tar.xz
community/grpc: fix i486 libatomic
Diffstat (limited to 'community/grpc')
-rw-r--r--community/grpc/PKGBUILD12
1 files changed, 12 insertions, 0 deletions
diff --git a/community/grpc/PKGBUILD b/community/grpc/PKGBUILD
new file mode 100644
index 00000000..05b3ada2
--- /dev/null
+++ b/community/grpc/PKGBUILD
@@ -0,0 +1,12 @@
+# -latomic on i486
+if [ "$CARCH" == 'i486' ]; then
+ eval "$(
+ declare -f prepare | \
+ sed '
+ s/cmake /cmake -DCMAKE_CXX_STANDARD_LIBRARIES=-latomic /
+ '
+ )"
+fi
+
+# Python tests failing due to LDFLAGS stuff, disabled for now
+unset check