summaryrefslogtreecommitdiff
path: root/community/arrayfire/arrayfire-full-3.6.0-no-cuda-backend-testing.patch
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-05-27 08:20:24 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2018-05-27 08:20:24 +0200
commit24c30f5e9479142383a8f43a3a2fb252ae518634 (patch)
tree97d652ffb7dba23d6173233f8220d6be7f46e122 /community/arrayfire/arrayfire-full-3.6.0-no-cuda-backend-testing.patch
parent01cf34e3f4a411326359941ded36d5664e4e1c3a (diff)
downloadpackages-24c30f5e9479142383a8f43a3a2fb252ae518634.tar.xz
community/arrayfire: patched for non-OpenCL testing and dim_t casts
Diffstat (limited to 'community/arrayfire/arrayfire-full-3.6.0-no-cuda-backend-testing.patch')
-rw-r--r--community/arrayfire/arrayfire-full-3.6.0-no-cuda-backend-testing.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/community/arrayfire/arrayfire-full-3.6.0-no-cuda-backend-testing.patch b/community/arrayfire/arrayfire-full-3.6.0-no-cuda-backend-testing.patch
new file mode 100644
index 00000000..f6904302
--- /dev/null
+++ b/community/arrayfire/arrayfire-full-3.6.0-no-cuda-backend-testing.patch
@@ -0,0 +1,16 @@
+diff -rauN arrayfire-full-3.6.0/test/CMakeLists.txt arrayfire-full-3.6.0-no-cuda-backend-testing-patch/test/CMakeLists.txt
+--- arrayfire-full-3.6.0/test/CMakeLists.txt 2018-05-02 20:53:08.000000000 +0200
++++ arrayfire-full-3.6.0-no-cuda-backend-testing-patch/test/CMakeLists.txt 2018-05-26 17:23:02.097495405 +0200
+@@ -49,9 +49,9 @@
+ list(APPEND enabled_backends "cuda")
+ endif(AF_BUILD_CUDA)
+
+-if(AF_BUILD_OPENCL)
+- list(APPEND enabled_backends "opencl")
+-endif(AF_BUILD_OPENCL)
++#if(AF_BUILD_OPENCL)
++# list(APPEND enabled_backends "opencl")
++#endif(AF_BUILD_OPENCL)
+
+ if(AF_BUILD_UNIFIED)
+ list(APPEND enabled_backends "unified")