summaryrefslogtreecommitdiff
path: root/build-support
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-05-02 17:37:18 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-05-02 17:37:18 +0200
commit6b6ec852fa60f10cbc58360c6290e71554bd0473 (patch)
tree067c626f27d70b0bdb7880f31c11eff4b907aebe /build-support
parent204b34c143ffddb072b0aeca3492c4f278883f9f (diff)
downloadpackages-6b6ec852fa60f10cbc58360c6290e71554bd0473.tar.xz
extra/wireplumber: moved to build-support (buildmaster is not happy with this package?!)
Diffstat (limited to 'build-support')
-rw-r--r--build-support/disabled/wireplumber/PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/build-support/disabled/wireplumber/PKGBUILD b/build-support/disabled/wireplumber/PKGBUILD
new file mode 100644
index 00000000..b853df0c
--- /dev/null
+++ b/build-support/disabled/wireplumber/PKGBUILD
@@ -0,0 +1,35 @@
+# disable documentation (needs sphinx, sphinx-rtd_theme, npm)
+# python-sphinx_rdt_theme needs npm, which is broken on archlinux32
+# most likely since years..
+makedepends=(${makedepends[@]//python-sphinx_rtd_theme/})
+makedepends=(${makedepends[@]//python-sphinx/})
+eval "$(
+ declare -f build | \
+ sed '
+ /local meson_options.*/ a \
+ meson_options+=(-D doc=disabled)
+ '
+ declare -f package_wireplumber | \
+ sed '
+ /_pick.*docs.*/d
+ '
+ declare -f package_wireplumber-docs | \
+ sed '
+ /mv.*docs.*/d
+ '
+)"
+
+# test-spa-json fails, ignoring for now
+eval "$(
+ declare -f check | \
+ sed '
+ s/\(meson test.*\)/\1 || true/g
+ '
+)"
+
+# for now disable testing on i486, doesn't work at all but we want
+# to satisfy dependencies and hope nobody uses it :)
+if [ "$CARCH" == 'i486' ]; then
+ unset check
+ unset checkdepends
+fi