summaryrefslogtreecommitdiff
path: root/build-support
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-01-01 21:23:02 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2022-01-01 21:23:02 +0100
commit144132feaabd8f382113729b4c305d0635e26fcd (patch)
tree0e7f83c7f12c8f21c79bbaf56f76bd96f0d9ffcb /build-support
parentc26d41170a5256a0045d3315c9fc98417882aad2 (diff)
downloadpackages-144132feaabd8f382113729b4c305d0635e26fcd.tar.xz
extra/python-setuptools: rebuild without manual egg-info copying (bootstrapping)
Diffstat (limited to 'build-support')
-rw-r--r--build-support/disabled/python-setuptools-egg-info-manually30
1 files changed, 30 insertions, 0 deletions
diff --git a/build-support/disabled/python-setuptools-egg-info-manually b/build-support/disabled/python-setuptools-egg-info-manually
new file mode 100644
index 00000000..9320e0b6
--- /dev/null
+++ b/build-support/disabled/python-setuptools-egg-info-manually
@@ -0,0 +1,30 @@
+# create directory before installing (otherwise installing fails)
+eval "$(
+ declare -f package | \
+ sed '
+ 4 i mkdir build/scripts-3.10
+ '
+)"
+
+# ignore errors in tests, but execute the tests
+eval "$(
+ declare -f check | \
+ sed '
+ s/\(python.*\)/\1 || true/
+ '
+)"
+
+unset checkdepends
+unset check
+
+# egg-infos are not installed correctly, create them before and install
+# them manually
+eval "$(
+ declare -f package | \
+ sed '
+ 6 i python setup.py egg_info \
+ rm -rf "$pkgdir"/usr/lib/python3.10/site-packages/setuptools-57.4.0-py3.10.egg-info \
+ mkdir "$pkgdir"/usr/lib/python3.10/site-packages/setuptools-57.4.0-py3.10.egg-info \
+ cp -R setuptools.egg-info/* "$pkgdir"/usr/lib/python3.10/site-packages/setuptools-57.4.0-py3.10.egg-info/.
+ '
+)"