summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-06-14 11:33:47 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2018-06-14 11:33:47 +0200
commitf55c38e6c33e945caa8a9bd8d6477ed103d1f595 (patch)
treee3203f68d0053aba5c25cf779f094ec87b916e9f
parentaa9038ea4d47c63ae5331f4d66be1c5e4b9a337b (diff)
downloadpackages-f55c38e6c33e945caa8a9bd8d6477ed103d1f595.tar.xz
community/fpc: fixed 32-bit symlink and TARGET_HOST probing
-rw-r--r--community/fpc/PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/community/fpc/PKGBUILD b/community/fpc/PKGBUILD
new file mode 100644
index 00000000..877a91f8
--- /dev/null
+++ b/community/fpc/PKGBUILD
@@ -0,0 +1,22 @@
+# symlink for 32-bit Pascal compiler
+
+# temporary:
+# the package has been built wrongly in the past, so we have to force
+# a ppc386 symlink in build (PP variable) because the Makefile is trying to
+# guess the target platform by executing fpc
+
+eval "$(
+ declare -f package | \
+ sed '
+ s@"$CARCH" = "x86_64"@"$CARCH" = "i686"@
+ s@ppcx64@ppc386@
+ '
+ declare -f build | \
+ sed '
+ s@NOGDB=1@NOGDB=1 PP=/usr/lib/fpc/$pkgver/ppc386 @
+ '
+ declare -f package | \
+ sed '
+ s@NOGDB=1@NOGDB=1 PP=/usr/lib/fpc/$pkgver/ppc386 @
+ '
+)"