summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-07-16 16:28:08 +0000
committerAndreas Baumann <mail@andreasbaumann.cc>2018-07-16 16:28:08 +0000
commite03ac06e8ee91bd485f91002fc5ad24b429feb09 (patch)
treedb01a3deeeca1ab42c052380565d4be4f798f5b3
parent63fb841721b772008d15aa10e9b0a4f4afe06b56 (diff)
parent089b5230767e3d52dfe93f2f550a23f0eca0a7a5 (diff)
downloadpackages-e03ac06e8ee91bd485f91002fc5ad24b429feb09.tar.xz
Merge branch 'master' into i486
-rw-r--r--core/kbd/PKGBUILD3
-rw-r--r--extra/python2/PKGBUILD8
2 files changed, 9 insertions, 2 deletions
diff --git a/core/kbd/PKGBUILD b/core/kbd/PKGBUILD
new file mode 100644
index 00000000..07c900a8
--- /dev/null
+++ b/core/kbd/PKGBUILD
@@ -0,0 +1,3 @@
+# we still get the FTP links, though trunk uses the proper URLs?!
+source[0]=https://www.kernel.org/pub/linux/utils/${pkgname}/${pkgname}-${pkgver}.tar.gz
+source[1]=https://www.kernel.org/pub/linux/utils/kbd/${pkgname}-${pkgver}.tar.sign
diff --git a/extra/python2/PKGBUILD b/extra/python2/PKGBUILD
index 080288e6..60148bdb 100644
--- a/extra/python2/PKGBUILD
+++ b/extra/python2/PKGBUILD
@@ -2,10 +2,14 @@
# test_replace_overflow (present in test_bytes, test_str, test_string,
# test_unicode, test_userstring) segfault on i686
# test_bigrepeat (present in test_tuple) segfault on i686
-# test_audioop (present in test_wrongsize, test_augassign, test_base64, test_bastion, test_bigaddrspace, test_max) AssertionError: -2147483648 != 2147483648L
+
eval "$(
+ declare -f build | \
+ sed '
+ /export OPT=/ s/"$/ -fwrapv"/
+ '
declare -f check | \
sed '
- /xvfb-run/ s/-x test_idle/-x test_idle test_bytes test_str test_string test_unicode test_userstring test_tuple test_wrongsize test_augassign test_base64 test_bastion test_bigaddrspace test_max test_audioop/
+ /xvfb-run/ s/-x test_idle/-x test_idle test_bytes test_str test_string test_unicode test_userstring test_tuple/
'
)"