summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-11-16 20:37:33 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2019-11-16 20:37:33 +0100
commitae1780d9136d30b46f8aa077e3234b0829fd99ae (patch)
treea603a95fbe3092909f0c6e3933b6356bd810c750
parenta88d4f51d2c59f450477509717d3149a37872569 (diff)
downloadpackages-ae1780d9136d30b46f8aa077e3234b0829fd99ae.tar.xz
build-support: renamed extra->disabled, added python-pip-bootstrap
-rw-r--r--build-support/disabled/ffmpeg/PKGBUILD (renamed from build-support/extra/ffmpeg/PKGBUILD)0
-rw-r--r--build-support/disabled/python-pip-bootstrap/.SRCINFO21
-rw-r--r--build-support/disabled/python-pip-bootstrap/PKGBUILD26
-rw-r--r--build-support/disabled/python-pip-bootstrap/install.sh4
-rw-r--r--build-support/disabled/python-pip-bootstrap/install2.sh4
-rw-r--r--build-support/disabled/rust-bin/PKGBUILD (renamed from build-support/extra/rust-bin/PKGBUILD)0
-rw-r--r--build-support/disabled/rust/PKGBUILD (renamed from build-support/extra/rust/PKGBUILD)0
-rw-r--r--build-support/disabled/rust/config.toml.patch (renamed from build-support/extra/rust/config.toml.patch)0
-rwxr-xr-xbuild-support/disabled/rust/watcher.sh (renamed from build-support/extra/rust/watcher.sh)0
9 files changed, 55 insertions, 0 deletions
diff --git a/build-support/extra/ffmpeg/PKGBUILD b/build-support/disabled/ffmpeg/PKGBUILD
index 9dbe9953..9dbe9953 100644
--- a/build-support/extra/ffmpeg/PKGBUILD
+++ b/build-support/disabled/ffmpeg/PKGBUILD
diff --git a/build-support/disabled/python-pip-bootstrap/.SRCINFO b/build-support/disabled/python-pip-bootstrap/.SRCINFO
new file mode 100644
index 00000000..d88edfcc
--- /dev/null
+++ b/build-support/disabled/python-pip-bootstrap/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-pip-bootstrap
+ pkgdesc = bootstap pip and setuptools for bootstrapping python
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://bootstrap.pypa.io/
+ arch = i486
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ source = https://bootstrap.pypa.io/get-pip.py
+ sha512sums = 29971130c5d1d1baf2b51ef689b40c91fcd0d1e62de6f99d6abef6879684a59843be539cd112dfddc3637cc3d1a91c79f775d80f6aa2fe920252710d48d2934d
+
+pkgname = python-pip-bootstrap
+ install = install.sh
+ depends = python
+
+pkgname = python2-pip-bootstrap
+ install = install2.sh
+ depends = python2
+
diff --git a/build-support/disabled/python-pip-bootstrap/PKGBUILD b/build-support/disabled/python-pip-bootstrap/PKGBUILD
new file mode 100644
index 00000000..93c5d86e
--- /dev/null
+++ b/build-support/disabled/python-pip-bootstrap/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Andreas Baumann <mail@andreasbaumann.cc>
+
+pkgname=('python-pip-bootstrap' 'python2-pip-bootstrap')
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="bootstap pip and setuptools for bootstrapping python"
+arch=(i486 'i686' 'x86_64' 'armv6h' 'armv7h')
+url="https://bootstrap.pypa.io/"
+source=("https://bootstrap.pypa.io/get-pip.py")
+sha512sums=('29971130c5d1d1baf2b51ef689b40c91fcd0d1e62de6f99d6abef6879684a59843be539cd112dfddc3637cc3d1a91c79f775d80f6aa2fe920252710d48d2934d')
+
+package_python-pip-bootstrap() {
+ depends=('python')
+ install=install.sh
+
+ mkdir -p "${pkgdir}/usr/bin"
+ cp "${srcdir}/get-pip.py" "${pkgdir}/usr/bin/."
+}
+
+package_python2-pip-bootstrap() {
+ depends=('python2')
+ install=install2.sh
+
+ mkdir -p "${pkgdir}/usr/bin"
+ cp "${srcdir}/get-pip.py" "${pkgdir}/usr/bin/get-pip2.py"
+}
diff --git a/build-support/disabled/python-pip-bootstrap/install.sh b/build-support/disabled/python-pip-bootstrap/install.sh
new file mode 100644
index 00000000..e81432e6
--- /dev/null
+++ b/build-support/disabled/python-pip-bootstrap/install.sh
@@ -0,0 +1,4 @@
+post_install() {
+ echo "Bootstrapping python pip, setuptools and wheel.."
+ python /usr/bin/get-pip.py
+}
diff --git a/build-support/disabled/python-pip-bootstrap/install2.sh b/build-support/disabled/python-pip-bootstrap/install2.sh
new file mode 100644
index 00000000..b6aa16fa
--- /dev/null
+++ b/build-support/disabled/python-pip-bootstrap/install2.sh
@@ -0,0 +1,4 @@
+post_install() {
+ echo "Bootstrapping python2 pip, setuptools and wheel.."
+ python2 /usr/bin/get-pip2.py
+}
diff --git a/build-support/extra/rust-bin/PKGBUILD b/build-support/disabled/rust-bin/PKGBUILD
index 125dac5f..125dac5f 100644
--- a/build-support/extra/rust-bin/PKGBUILD
+++ b/build-support/disabled/rust-bin/PKGBUILD
diff --git a/build-support/extra/rust/PKGBUILD b/build-support/disabled/rust/PKGBUILD
index b94c4e14..b94c4e14 100644
--- a/build-support/extra/rust/PKGBUILD
+++ b/build-support/disabled/rust/PKGBUILD
diff --git a/build-support/extra/rust/config.toml.patch b/build-support/disabled/rust/config.toml.patch
index 8d0762cd..8d0762cd 100644
--- a/build-support/extra/rust/config.toml.patch
+++ b/build-support/disabled/rust/config.toml.patch
diff --git a/build-support/extra/rust/watcher.sh b/build-support/disabled/rust/watcher.sh
index 544c3712..544c3712 100755
--- a/build-support/extra/rust/watcher.sh
+++ b/build-support/disabled/rust/watcher.sh