summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-06-13 09:12:32 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-06-13 09:12:32 +0200
commit9b77ba821b9814f5930c98926ba96395c238daec (patch)
tree9bbb013f9eeda64e2b800b18aa32a6baca4fe0ee
parente1e83c909cdafd2c0c33776d24789373abed09b4 (diff)
downloadpackages-9b77ba821b9814f5930c98926ba96395c238daec.tar.xz
community/arrayfire: blacklisted
-rw-r--r--blacklist1
-rw-r--r--community/arrayfire/PKGBUILD34
-rw-r--r--community/arrayfire/arrayfire-full-3.6.0-no-cuda-backend-testing.patch16
-rw-r--r--community/arrayfire/arrayfire-full-3.6.3-dim-cast.patch36
4 files changed, 1 insertions, 86 deletions
diff --git a/blacklist b/blacklist
index 764b3064..d41c528d 100644
--- a/blacklist
+++ b/blacklist
@@ -1,3 +1,4 @@
+pentium4 arrayfire # "We neither test/build on 32bit architecture nor claim 32bit support."
pentium4 byzanz # blacklisted, blocks slaves, see FS#62399
pentium4 bazel # reports are there for making 32-bit compile, see <a href="https://github.com/bazelbuild/bazel/issues/3643">upstream</a>
pentium4 ceph # fails fatally in check() - see <a href="https://bugs.archlinux32.org/index.php?do=details&task_id=21">FS32#21</a>
diff --git a/community/arrayfire/PKGBUILD b/community/arrayfire/PKGBUILD
deleted file mode 100644
index bd3a63e3..00000000
--- a/community/arrayfire/PKGBUILD
+++ /dev/null
@@ -1,34 +0,0 @@
-# modern cuda is no longer available for 32-bit
-makedepends=(${makedepends[@]//cuda/})
-
-# force 32-bit compilation
-eval "$(
- declare -f build | \
- sed '
- /^{/{
- a\
- export CFLAGS+=" -m32" \
- export CXXFLAGS+=" -m32"
- }
- '
-)"
-
-# compilation issues around dim_t casts, see https://github.com/arrayfire/arrayfire/issues/2161
-source+=(arrayfire-full-3.6.3-dim-cast.patch)
-sha512sums+=('717535d030973723e0f028dc7e86ccbe46c6661146cfe0fd2e26bef77d08f11af35e0971e53ad0d11ce23d5dca48f29247fb8cc2fce8a06d13c0e24d89e5ae2c')
-eval "$(
- declare -f prepare | \
- sed '
- /cd /a patch -Np1 -i ${srcdir}/arrayfire-full-3.6.3-dim-cast.patch
- '
-)"
-
-# no more CUDA support for 32-bit Linux
-source+=(arrayfire-full-3.6.0-no-cuda-backend-testing.patch)
-sha512sums+=('7c5912ecf59932a4c00f859190174b5b88f01010d131dfef4b013940543f157698d048297eb8c86e1d5289df8f7eb6d769fd39f069b7bf3262800ceca98d09fc')
-eval "$(
- declare -f prepare | \
- sed '
- /cd /a patch -Np1 -i ${srcdir}/arrayfire-full-3.6.0-no-cuda-backend-testing.patch
- '
-)"
diff --git a/community/arrayfire/arrayfire-full-3.6.0-no-cuda-backend-testing.patch b/community/arrayfire/arrayfire-full-3.6.0-no-cuda-backend-testing.patch
deleted file mode 100644
index f6904302..00000000
--- a/community/arrayfire/arrayfire-full-3.6.0-no-cuda-backend-testing.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -rauN arrayfire-full-3.6.0/test/CMakeLists.txt arrayfire-full-3.6.0-no-cuda-backend-testing-patch/test/CMakeLists.txt
---- arrayfire-full-3.6.0/test/CMakeLists.txt 2018-05-02 20:53:08.000000000 +0200
-+++ arrayfire-full-3.6.0-no-cuda-backend-testing-patch/test/CMakeLists.txt 2018-05-26 17:23:02.097495405 +0200
-@@ -49,9 +49,9 @@
- list(APPEND enabled_backends "cuda")
- endif(AF_BUILD_CUDA)
-
--if(AF_BUILD_OPENCL)
-- list(APPEND enabled_backends "opencl")
--endif(AF_BUILD_OPENCL)
-+#if(AF_BUILD_OPENCL)
-+# list(APPEND enabled_backends "opencl")
-+#endif(AF_BUILD_OPENCL)
-
- if(AF_BUILD_UNIFIED)
- list(APPEND enabled_backends "unified")
diff --git a/community/arrayfire/arrayfire-full-3.6.3-dim-cast.patch b/community/arrayfire/arrayfire-full-3.6.3-dim-cast.patch
deleted file mode 100644
index a12be27f..00000000
--- a/community/arrayfire/arrayfire-full-3.6.3-dim-cast.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -rauN arrayfire-full-3.6.3/src/api/c/homography.cpp arrayfire-full-3.6.3-dim-cast/src/api/c/homography.cpp
---- arrayfire-full-3.6.3/src/api/c/homography.cpp 2019-04-22 19:43:11.000000000 +0200
-+++ arrayfire-full-3.6.3-dim-cast/src/api/c/homography.cpp 2019-05-10 10:56:16.706666685 +0200
-@@ -30,7 +30,7 @@
- Array<T> bestH = createEmptyArray<T>(af::dim4(3, 3));
- af_array initial;
- unsigned d = (iterations + 256 - 1) / 256;
-- dim_t rdims[] = {4, d * 256};
-+ dim_t rdims[] = {4, static_cast<dim_t>(d) * 256};
- AF_CHECK(af_randu(&initial, 2, rdims, f32));
- inliers =
- homography<T>(bestH, getArray<float>(x_src), getArray<float>(y_src),
-diff -rauN arrayfire-full-3.6.3/src/backend/opencl/kernel/ireduce.hpp arrayfire-full-3.6.3-dim-cast/src/backend/opencl/kernel/ireduce.hpp
---- arrayfire-full-3.6.3/src/backend/opencl/kernel/ireduce.hpp 2019-04-22 19:43:11.000000000 +0200
-+++ arrayfire-full-3.6.3-dim-cast/src/backend/opencl/kernel/ireduce.hpp 2019-05-10 10:57:31.576666685 +0200
-@@ -308,7 +308,7 @@
- uint groups_x = divup(in.info.dims[0], threads_x * REPEAT);
- uint groups_y = divup(in.info.dims[1], threads_y);
- Array<T> tmp = createEmptyArray<T>(
-- {groups_x, in.info.dims[1], in.info.dims[2], in.info.dims[3]});
-+ {static_cast<dim_t>(groups_x), in.info.dims[1], in.info.dims[2], in.info.dims[3]});
-
- int tmp_elements = tmp.elements();
- cl::Buffer *tidx = bufferAlloc(tmp_elements * sizeof(uint));
-diff -rauN arrayfire-full-3.6.3/src/backend/opencl/kernel/reduce.hpp arrayfire-full-3.6.3-dim-cast/src/backend/opencl/kernel/reduce.hpp
---- arrayfire-full-3.6.3/src/backend/opencl/kernel/reduce.hpp 2019-04-22 19:43:11.000000000 +0200
-+++ arrayfire-full-3.6.3-dim-cast/src/backend/opencl/kernel/reduce.hpp 2019-05-10 10:58:02.416666685 +0200
-@@ -263,7 +263,7 @@
- uint groups_x = divup(in.info.dims[0], threads_x * REPEAT);
- uint groups_y = divup(in.info.dims[1], threads_y);
- Array<To> tmp = createEmptyArray<To>(
-- {groups_x, in.info.dims[1], in.info.dims[2], in.info.dims[3]});
-+ {{static_cast<dim_t>(groups_x), in.info.dims[1], in.info.dims[2], in.info.dims[3]});
-
- int tmp_elements = tmp.elements();
-