summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-07-19 11:20:58 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2018-07-19 11:20:58 +0200
commit776547f328f50fb9a8a3cc996e238a7dc1573f36 (patch)
tree40a2213d4927c86024f52cf1ad370358ae2c574c
parentb64e0b3dbff5e76b791843eb2f82c6e9efe963d8 (diff)
downloadpackages-776547f328f50fb9a8a3cc996e238a7dc1573f36.tar.xz
core/make: fix for FS#59387 (segfaults in globs)
-rw-r--r--core/make/0001-glob-Do-not-assume-glibc-glob-internals.patch64
-rw-r--r--core/make/PKGBUILD6
2 files changed, 68 insertions, 2 deletions
diff --git a/core/make/0001-glob-Do-not-assume-glibc-glob-internals.patch b/core/make/0001-glob-Do-not-assume-glibc-glob-internals.patch
new file mode 100644
index 00000000..b88ebcaf
--- /dev/null
+++ b/core/make/0001-glob-Do-not-assume-glibc-glob-internals.patch
@@ -0,0 +1,64 @@
+From 193f1e81edd6b1b56b0eb0ff8aa4b41c7b4257b4 Mon Sep 17 00:00:00 2001
+From: Paul Eggert <eggert@cs.ucla.edu>
+Date: Sun, 24 Sep 2017 09:12:58 -0400
+Subject: [PATCH 01/26] glob: Do not assume glibc glob internals.
+
+It has been proposed that glibc glob start using gl_lstat,
+which the API allows it to do. GNU 'make' should not get in
+the way of this. See:
+https://sourceware.org/ml/libc-alpha/2017-09/msg00409.html
+
+* dir.c (local_lstat): New function, like local_stat.
+(dir_setup_glob): Use it to initialize gl_lstat too, as the API
+requires.
+
+diff --git a/dir.c b/dir.c
+index adbb8a9..c343e4c 100644
+--- a/dir.c
++++ b/dir.c
+@@ -1299,15 +1299,40 @@ local_stat (const char *path, struct stat *buf)
+ }
+ #endif
+
++/* Similarly for lstat. */
++#if !defined(lstat) && !defined(WINDOWS32) || defined(VMS)
++# ifndef VMS
++# ifndef HAVE_SYS_STAT_H
++int lstat (const char *path, struct stat *sbuf);
++# endif
++# else
++ /* We are done with the fake lstat. Go back to the real lstat */
++# ifdef lstat
++# undef lstat
++# endif
++# endif
++# define local_lstat lstat
++#elif defined(WINDOWS32)
++/* Windows doesn't support lstat(). */
++# define local_lstat local_stat
++#else
++static int
++local_lstat (const char *path, struct stat *buf)
++{
++ int e;
++ EINTRLOOP (e, lstat (path, buf));
++ return e;
++}
++#endif
++
+ void
+ dir_setup_glob (glob_t *gl)
+ {
+ gl->gl_opendir = open_dirstream;
+ gl->gl_readdir = read_dirstream;
+ gl->gl_closedir = free;
++ gl->gl_lstat = local_lstat;
+ gl->gl_stat = local_stat;
+- /* We don't bother setting gl_lstat, since glob never calls it.
+- The slot is only there for compatibility with 4.4 BSD. */
+ }
+
+ void
+--
+2.18.0
+
diff --git a/core/make/PKGBUILD b/core/make/PKGBUILD
index 0696a710..45ca70ce 100644
--- a/core/make/PKGBUILD
+++ b/core/make/PKGBUILD
@@ -1,10 +1,12 @@
-source+=('FS55127.patch' 'FS58674.patch')
-md5sums+=('8efba0d7ff90f5394edda0f83259af05' '95fcc032a728e134f620a402e6922389')
+source+=('FS55127.patch' 'FS58674.patch' '0001-glob-Do-not-assume-glibc-glob-internals.patch')
+md5sums+=('8efba0d7ff90f5394edda0f83259af05' '95fcc032a728e134f620a402e6922389' 'a68d9cdcde0287bd2cc253a7722a2893')
eval "$(
declare -f prepare | \
sed '
/^\s*cd\s/a patch -p1 -i ${srcdir}/FS55127.patch
/^\s*cd\s/a patch -p1 -i ${srcdir}/FS58674.patch
+ /^\s*cd\s/a patch -p1 -i ${srcdir}/0001-glob-Do-not-assume-glibc-glob-internals.patch
'
)"
+