summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-05-06 20:58:03 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-05-06 20:58:03 +0200
commit5d46417fe35dfbf478468efc87f9b1c39e0b542e (patch)
tree7112edc94b3b570e3c1f8165189a98ea93ad892a
parent19d360c0dfcb01ce678542b499cd82e98b80e96b (diff)
downloadpackages-5d46417fe35dfbf478468efc87f9b1c39e0b542e.tar.xz
extra/python-numpy: fixed compilation flags for SSE and friends
-rw-r--r--extra/python-numpy/PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/extra/python-numpy/PKGBUILD b/extra/python-numpy/PKGBUILD
new file mode 100644
index 00000000..6e15ddae
--- /dev/null
+++ b/extra/python-numpy/PKGBUILD
@@ -0,0 +1,17 @@
+# enable SSE/SSE2 on pentium4, no optimizations on i686 and i486
+if [ "${CARCH}" = "i486" -o "${CARCH}" = "i686" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s|python setup.py build|python setup.py build --cpu-baseline=NONE --cpu-dispatch=NONE|
+ '
+ )"
+fi
+if [ "${CARCH}" = "pentium4" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s|python setup.py build|python setup.py build --cpu-baseline=NONE --cpu-dispatch=SSE,SSE2|
+ '
+ )"
+fi