summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-02-06 08:14:51 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2022-02-06 08:14:51 +0100
commit505a3908e8a4196707ca63bc27f36ccac64e01b9 (patch)
treeef447c4c54bd7221709a4b75db493e2cdb95b8c6
parent753ccc08dea3a8bf5a9a079d5f9e014723d08fd2 (diff)
downloadpackages-505a3908e8a4196707ca63bc27f36ccac64e01b9.tar.xz
core/linux: enabling CONFIG_DEBUG_INFO_BTF for resolve_btfids
-rw-r--r--core/linux/PKGBUILD6
-rw-r--r--core/linux/config.i4862
-rw-r--r--core/linux/config.i6862
-rw-r--r--core/linux/config.pentium42
4 files changed, 6 insertions, 6 deletions
diff --git a/core/linux/PKGBUILD b/core/linux/PKGBUILD
index d7773d83..e5da211f 100644
--- a/core/linux/PKGBUILD
+++ b/core/linux/PKGBUILD
@@ -6,9 +6,9 @@ source_i486=('config.i486')
# fail if upstream's .config changes
for ((i=0; i<${#sha256sums[@]}; i++)); do
if [ "${sha256sums[${i}]}" = '7cbba374356a189faac71001c5344ce8f02434684b1ce1accefc0cc4bd6718e5' ]; then
- sha256sums_pentium4=('b7aed5f5f350e2c3c115c97dc1458d42b895f214692ae749da87959e1c211f22')
- sha256sums_i686=('a34119a137c81821966c07368945a42e016f6b6969b21f8a6bad6153822dd7c1')
- sha256sums_i486=('987dc1e6b6da0d58ceffca2c82be927be91c551e0ff4ace901d9c6235c55fec5')
+ sha256sums_pentium4=('703e34a4a20b6f02f4a0dd81d0036453ffcde3d17d0bc60c6d08bdb151fcd673')
+ sha256sums_i686=('2ab56abacb29e57bc6ec57e41cb23091b2769948f6d72d7e3cd86c41b6b56426')
+ sha256sums_i486=('680f8587161e057a7231f0398b3faf12b57cf5df9b6615ff1e465862fca45116')
fi
done
diff --git a/core/linux/config.i486 b/core/linux/config.i486
index 7beadf5a..0bb4496b 100644
--- a/core/linux/config.i486
+++ b/core/linux/config.i486
@@ -10571,7 +10571,7 @@ CONFIG_DEBUG_INFO=y
# CONFIG_DEBUG_INFO_DWARF_TOOLCHAIN_DEFAULT is not set
CONFIG_DEBUG_INFO_DWARF4=y
# CONFIG_DEBUG_INFO_DWARF5 is not set
-# CONFIG_DEBUG_INFO_BTF is not set
+CONFIG_DEBUG_INFO_BTF=y
CONFIG_PAHOLE_HAS_SPLIT_BTF=y
# CONFIG_GDB_SCRIPTS is not set
CONFIG_FRAME_WARN=1024
diff --git a/core/linux/config.i686 b/core/linux/config.i686
index 53c7ec97..172dd9df 100644
--- a/core/linux/config.i686
+++ b/core/linux/config.i686
@@ -10635,7 +10635,7 @@ CONFIG_DEBUG_INFO=y
# CONFIG_DEBUG_INFO_DWARF_TOOLCHAIN_DEFAULT is not set
CONFIG_DEBUG_INFO_DWARF4=y
# CONFIG_DEBUG_INFO_DWARF5 is not set
-# CONFIG_DEBUG_INFO_BTF is not set
+CONFIG_DEBUG_INFO_BTF=y
CONFIG_PAHOLE_HAS_SPLIT_BTF=y
# CONFIG_GDB_SCRIPTS is not set
CONFIG_FRAME_WARN=1024
diff --git a/core/linux/config.pentium4 b/core/linux/config.pentium4
index ca96f502..30b41b5d 100644
--- a/core/linux/config.pentium4
+++ b/core/linux/config.pentium4
@@ -10641,7 +10641,7 @@ CONFIG_DEBUG_INFO=y
# CONFIG_DEBUG_INFO_DWARF_TOOLCHAIN_DEFAULT is not set
CONFIG_DEBUG_INFO_DWARF4=y
# CONFIG_DEBUG_INFO_DWARF5 is not set
-# CONFIG_DEBUG_INFO_BTF is not set
+CONFIG_DEBUG_INFO_BTF=y
CONFIG_PAHOLE_HAS_SPLIT_BTF=y
# CONFIG_GDB_SCRIPTS is not set
CONFIG_FRAME_WARN=1024